summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-06 08:33:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-06 08:33:58 +0200
commitb0386621ec3d3d4916eef1667b29f7cc44655706 (patch)
treeda7c3559b680f48fb56b6a3768de61bfd8a58a02
parentdev-ruby/fakefs: cleanup (diff)
downloadgentoo-b0386621.tar.gz
gentoo-b0386621.tar.bz2
gentoo-b0386621.zip
dev-python/django-taggit: Bump to 1.5.1
Closes: https://bugs.gentoo.org/784260 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-taggit/Manifest1
-rw-r--r--dev-python/django-taggit/django-taggit-1.5.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/django-taggit/Manifest b/dev-python/django-taggit/Manifest
index 8139cb288d6b..66c1a82b4971 100644
--- a/dev-python/django-taggit/Manifest
+++ b/dev-python/django-taggit/Manifest
@@ -1 +1,2 @@
DIST django-taggit-1.3.0.tar.gz 46986 BLAKE2B ebe425bc17b67977d40c56b9072ef471e1239090056667f1a5792f005908cbffc31f9eb863575ff7d3d359ebef7263e085bad5b7b481ed9060720bd59f617bb3 SHA512 bd5a537fc11bc4b434a5dbbc11e583acb3878101fcfa7e24af3aca5f160e2f1ac8defc9454c0814d39eb47bbb8edea8d3cf47627ad4b4dc86b962cd69d415ccd
+DIST django-taggit-1.5.1.tar.gz 52766 BLAKE2B 59892ba591ad5cbc40a7515a6427722d7cb58e2daadec579b1c08dcc3522e24e041cbe06c953c3717cdf3db50aef7ff9fb5b4eac00344e457b61797745638107 SHA512 8e7afefd8f0654340e234f7bd1cc3684b3e5d1f4d94d17c79ed8fb82096c21a809e7f8db2fea9509d45c3f2bdc5e8ed52fb0823779b0a039f87528642803725b
diff --git a/dev-python/django-taggit/django-taggit-1.5.1.ebuild b/dev-python/django-taggit/django-taggit-1.5.1.ebuild
new file mode 100644
index 000000000000..27e3b3afdeea
--- /dev/null
+++ b/dev-python/django-taggit/django-taggit-1.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Simple tagging for Django"
+HOMEPAGE="https://github.com/jazzband/django-taggit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings=tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}