summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2022-01-20 10:06:39 -0500
committerRick Farina <zerochaos@gentoo.org>2022-01-20 12:04:41 -0500
commitb04ab98040a7e7e15bd0297cd06218ce9108f153 (patch)
treef2f90d52942d3a95123513fb2292d86ba7185dc7
parentnet-misc/chrony: Stabilize 4.2 ppc64, #831576 (diff)
downloadgentoo-b04ab980.tar.gz
gentoo-b04ab980.tar.bz2
gentoo-b04ab980.zip
net-wireless/kismet: fix missing use dep
Signed-off-by: Rick Farina <zerochaos@gentoo.org> Closes: https://bugs.gentoo.org/828011 Bump python support to 10 Bump eapi 7->8 remove unused eclass
-rw-r--r--net-wireless/kismet/kismet-2021.08.1-r1.ebuild (renamed from net-wireless/kismet/kismet-2021.08.1.ebuild)12
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/net-wireless/kismet/kismet-2021.08.1.ebuild b/net-wireless/kismet/kismet-2021.08.1-r1.ebuild
index 45462e528503..e82c719234ad 100644
--- a/net-wireless/kismet/kismet-2021.08.1.ebuild
+++ b/net-wireless/kismet/kismet-2021.08.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
-inherit autotools multilib python-single-r1 udev systemd
+inherit autotools python-single-r1 udev systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
@@ -46,7 +46,7 @@ CDEPEND="
sys-libs/zlib:=
dev-db/sqlite:=
net-libs/libmicrohttpd:=
- net-libs/libwebsockets:=[client]
+ net-libs/libwebsockets:=[client,lejp]
kernel_linux? ( sys-libs/libcap
dev-libs/libnl:3
net-libs/libpcap
@@ -175,7 +175,7 @@ pkg_preinst() {
migrate_config() {
einfo "Kismet Configuration files are now read from /etc/kismet/"
ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
- if [ -n "$(ls ${EROOT}/etc/kismet_*.conf 2> /dev/null)" ]; then
+ if [ -n "$(ls "${EROOT}"/etc/kismet_*.conf 2> /dev/null)" ]; then
ewarn "Files at /etc/kismet_*.conf will not be read and should be removed"
fi
if [ -f "${EROOT}/etc/kismet_site.conf" ] && [ ! -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 45462e528503..e82c719234ad 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
-inherit autotools multilib python-single-r1 udev systemd
+inherit autotools python-single-r1 udev systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
@@ -46,7 +46,7 @@ CDEPEND="
sys-libs/zlib:=
dev-db/sqlite:=
net-libs/libmicrohttpd:=
- net-libs/libwebsockets:=[client]
+ net-libs/libwebsockets:=[client,lejp]
kernel_linux? ( sys-libs/libcap
dev-libs/libnl:3
net-libs/libpcap
@@ -175,7 +175,7 @@ pkg_preinst() {
migrate_config() {
einfo "Kismet Configuration files are now read from /etc/kismet/"
ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
- if [ -n "$(ls ${EROOT}/etc/kismet_*.conf 2> /dev/null)" ]; then
+ if [ -n "$(ls "${EROOT}"/etc/kismet_*.conf 2> /dev/null)" ]; then
ewarn "Files at /etc/kismet_*.conf will not be read and should be removed"
fi
if [ -f "${EROOT}/etc/kismet_site.conf" ] && [ ! -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then