summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-07 11:23:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-07 11:27:08 +0100
commitb04cf71a502371aba04e99f7922c4ae1f20a106b (patch)
treee76c8fe75235abbdd4578ee3d83308386607516e
parentapp-i18n/tegaki-zinnia-japanese: update to EAPI 8 (diff)
downloadgentoo-b04cf71a.tar.gz
gentoo-b04cf71a.tar.bz2
gentoo-b04cf71a.zip
dev-python/certifi: Switch to certifi-system-store, v3021.3.16
Switch to a third-party certifi-system-store package that seems a little bit more robust than my certifi-shim, and most importantly -- it is maintained by somebody else ;-). Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/certifi/Manifest1
-rw-r--r--dev-python/certifi/certifi-3021.3.16.ebuild55
-rw-r--r--dev-python/certifi/metadata.xml3
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
index dd748ac592ee..7640968ec158 100644
--- a/dev-python/certifi/Manifest
+++ b/dev-python/certifi/Manifest
@@ -1 +1,2 @@
DIST certifi-shim-10001.tar.gz 4061 BLAKE2B 183c573b958921877b14e38e9e26842e8a4f1c1617979a30b65ef1e2bbf001e5ff0aab830e4399906a7d21fb3c71ac12b1e757e4d283aae16cced8e7de7c2a1d SHA512 93beea61e579b2b414bd37c63eba49365e0a1a62304e0c7ac920bedaf5d72cb095a4a46b2240b3c2e6ee31e5b91cd520ae8348b6a8033212d11bbca31db6750c
+DIST certifi-system-store-3021.3.16.tar.gz 13784 BLAKE2B c0c2322fe298d363c4ef4dada2c0db8837bf7a32d86a7b54a1b45bb3dd3c99d732b2612f25495f4a59d9692f896e2b962e7057fa5fec9998724476db48f90c2a SHA512 44953ed8a3deb5fa4aff3f74afa557219e042acea395e9cdebfd26fd43ce0bdeca07c6b6dfe91977f88852e7674b94337b93c4d78fd2da6f47a6187fa46d6668
diff --git a/dev-python/certifi/certifi-3021.3.16.ebuild b/dev-python/certifi/certifi-3021.3.16.ebuild
new file mode 100644
index 000000000000..9fb5fa1b8014
--- /dev/null
+++ b/dev-python/certifi/certifi-3021.3.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=certifi-system-store-${PV}
+DESCRIPTION="A certifi hack to use system trust store on Linux/FreeBSD"
+HOMEPAGE="
+ https://github.com/tiran/certifi-system-store/
+ https://pypi.org/project/certifi-system-store/"
+SRC_URI="
+ https://github.com/tiran/certifi-system-store/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="app-misc/ca-certificates"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_IGNORE=(
+ # requires Internet
+ tests/test_requests.py
+)
+
+src_prepare() {
+ sed -i -e "s^/etc^${EPREFIX}/etc^" src/certifi/core.py || die
+ distutils-r1_src_prepare
+}
+
+symlink_info() {
+ pushd "${1}" >/dev/null || die
+ local egginfo=( certifi_system_store*.egg-info )
+ [[ -d ${egginfo} ]] || die
+ ln -v -s "${egginfo}" "${egginfo/_system_store}" || die
+ popd >/dev/null || die
+}
+
+python_test() {
+ distutils_install_for_testing
+ symlink_info "${TEST_DIR}"/lib
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install
+ symlink_info "${D}$(python_get_sitedir)"
+}
diff --git a/dev-python/certifi/metadata.xml b/dev-python/certifi/metadata.xml
index 8af22c60e688..db64a2b878fe 100644
--- a/dev-python/certifi/metadata.xml
+++ b/dev-python/certifi/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">certifi</remote-id>
+ <remote-id type="github">tiran/certifi-system-store</remote-id>
+ <remote-id type="pypi">certifi-system-store</remote-id>
</upstream>
</pkgmetadata>