summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 00:39:09 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 00:39:09 +0100
commitb052863fec72b9eb6bca023bc36d289bfaa78f4c (patch)
tree354dd07a0eabe753fcdd8b980c6a553b2d9d35e5
parentdev-python/huawei-lte-api: Bump to 1.5.4 (diff)
downloadgentoo-b052863fec72b9eb6bca023bc36d289bfaa78f4c.tar.gz
gentoo-b052863fec72b9eb6bca023bc36d289bfaa78f4c.tar.bz2
gentoo-b052863fec72b9eb6bca023bc36d289bfaa78f4c.zip
sys-libs/llvm-libunwind: Fix forcing test compiler in 14.x
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
index c4a1e07a077f..a9e274cc99af 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
@@ -67,17 +67,23 @@ multilib_src_configure() {
-DLIBUNWIND_USE_COMPILER_RT=${use_compiler_rt}
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
)
fi
cmake_src_configure
+
+ if use test; then
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+
+ # meh, we need to override the compiler explicitly
+ sed -e "/%{cxx}/s@, '.*'@, '${clang_path}'@" \
+ -i "${BUILD_DIR}"/test/lit.site.cfg || die
+ fi
}
wrap_libcxxabi() {