summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-02 07:54:27 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-02 09:21:17 +0200
commitb08c7c0d1221c6b358b98858b146b16e1824b7a9 (patch)
treefd032d8aac2d97f86f0a07f6b81223e07466e674
parentmedia-sound/strawberry: bump to 1.0.18 + added ~arm64 to live (diff)
downloadgentoo-b08c7c0d1221c6b358b98858b146b16e1824b7a9.tar.gz
gentoo-b08c7c0d1221c6b358b98858b146b16e1824b7a9.tar.bz2
gentoo-b08c7c0d1221c6b358b98858b146b16e1824b7a9.zip
dev-ml/ocaml_intrinsics: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/ocaml_intrinsics/Manifest1
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/Manifest b/dev-ml/ocaml_intrinsics/Manifest
index 90d21a5feefc..76ee115558d3 100644
--- a/dev-ml/ocaml_intrinsics/Manifest
+++ b/dev-ml/ocaml_intrinsics/Manifest
@@ -1,2 +1,3 @@
DIST ocaml_intrinsics-0.15.1.tar.gz 24925 BLAKE2B 15d74ee891aced288aa734ef4d70a4816f2d2725d0d445620154bec7d1667d3ac06c5ddd778777d15858cbf198ecd978b22959fe68e159ddd9dbbd32304c3077 SHA512 cb0ac26bc34c97eb0429e6833342dbd9fca6f1f4a40b8121f9e6364bd2cdc40676a164d7405454727ced9a4455adb0e3cac5118beb7ab70206adbd3e7f7937e2
DIST ocaml_intrinsics-0.15.2.tar.gz 24977 BLAKE2B eea2af5ff746cfd7b483df47a8f719c623eecc8bf82d852ed69395752e98ebb94a555ef2dd95271d45941a5582f7ff139f8e79d5dd8adf5389786aff756df7fe SHA512 21539fecd8b40420bdb45a3fe79f65cf4ff0deb103c3cb2b28bad24fddce159bdfab3f7aa6ade0028bebef1602f860b1f6cdf2cc06db1a89e232b221d8ff592b
+DIST ocaml_intrinsics-0.16.0.tar.gz 35876 BLAKE2B fc9ead65244efe96ea130426265acb2cccc08105e53383ddfd7117bca461e28095f213f22dddafc1e3f6490ad2b4f0d4e9129a8dcf8dc207269ca83eb889acee SHA512 86bf6ac7cb1da5de03224cc053e174ec22af766b6c5ab4ca1fde3c028405858cb97feeae6968d9054a7d6994491b9f2cdb8e198ee837ad4242f9cd812873ceaa
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild
new file mode 100644
index 000000000000..7e383a4f2da6
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Invoke amd64 instructions (such as clz, popcnt, rdtsc, rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics/"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"