summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-04-08 20:10:44 -0400
committerCraig Andrews <candrews@gentoo.org>2021-04-08 20:11:23 -0400
commitb0a0123c1905cdfaae596c61c993b06e8607e250 (patch)
tree4b8e2e83c505205e56356ef2ae79512c2080bf67
parentxfce-extra/xfdashboard: Bump to 0.9.2 (diff)
downloadgentoo-b0a0123c.tar.gz
gentoo-b0a0123c.tar.bz2
gentoo-b0a0123c.zip
net-p2p/cpuminer-opt: 3.16.2 version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.16.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 4f124dcda639..2a10bfe1dc6c 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.14.3.tar.gz 1822560 BLAKE2B 82e632577b0bd910c8a5bf1fa37bacc27c45ade178456113b986d070b46b7394eddaebcbff675d3cf842dc4f63253133244af1a706159a714ab8c043cd762e8c SHA512 ad8700a1ca0eca34cf9b15235e8c413ab7250dd47c6e1eba6a0b8c81665e7fa4aaef981f601a876d3973ef06cdbe7df56ce2d3827a5bac6de63434f1faf1d771
+DIST cpuminer-opt-3.16.2.tar.gz 1829567 BLAKE2B 01f0383f1e6f46bb71c548df5f69e808e7ccaa3aa7217530464b86bc629843f632405f9ca57f9201cd337e774ebe8ca6fa2fe8b8ec0e0042bb0844d8bd9f6c0c SHA512 bc0d9970afee6f6d5cdfbe7517c7d201fccb9ef133dc51494b03bfa1b4e0e8e40927cffee8ff811b077f6d39b2bc61e96bba1c162f68470fd702e1b3383a6357
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.16.2.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.16.2.ebuild
new file mode 100644
index 000000000000..b82ff43b0b84
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.16.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}