summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 23:40:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 23:40:37 +0200
commitb0af210b4fbfb361b6909300e5914d1898394735 (patch)
tree94caa37d4ae06d9b0014666678bebd338797d4d6
parentdev-python/pytest-toolbox: Fix running tests (diff)
downloadgentoo-b0af210b4fbfb361b6909300e5914d1898394735.tar.gz
gentoo-b0af210b4fbfb361b6909300e5914d1898394735.tar.bz2
gentoo-b0af210b4fbfb361b6909300e5914d1898394735.zip
dev-python/immutables: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/immutables/Manifest1
-rw-r--r--dev-python/immutables/immutables-0.16.ebuild30
2 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/immutables/Manifest b/dev-python/immutables/Manifest
index 403c1694072c..5939dda7cf71 100644
--- a/dev-python/immutables/Manifest
+++ b/dev-python/immutables/Manifest
@@ -1,2 +1 @@
-DIST immutables-0.16.tar.gz 84916 BLAKE2B e699aaa1135fa9f7db9589276dc0801a67c5f98bd3c5b247913d8263f9baf02a8772d7715cc3eb2c9392694d48d3808d50f45e9fe8e66c4d507586d0e3fdc319 SHA512 5b883cfe43f8a042b617e719dccd3cbdded3b1d1df160ba26b6bb2f0816a7171698bdd2ba3d450e76f135b236e777052a22c09b8bd1a9183227f1ccc90617cf8
DIST immutables-0.17.gh.tar.gz 84660 BLAKE2B 475042d6342e3ffe5b4aa68e2e8c27a438658214ec2aa6439e077d59d2e2257313f644f535ebfbdb171b0e7dac33cde590f8a84a8da9da717b249e5b2e11ca92 SHA512 d5853de6b7c6064c93b6dbf66819873c982dd2e155ddcbf6b5dd321475374e9f52eb683c853a6944c71ca15fb194ac9480ad2d444407c885ee574c244c4f081a
diff --git a/dev-python/immutables/immutables-0.16.ebuild b/dev-python/immutables/immutables-0.16.ebuild
deleted file mode 100644
index bff5d2a27f79..000000000000
--- a/dev-python/immutables/immutables-0.16.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A high-performance immutable mapping type for Python"
-HOMEPAGE="https://github.com/MagicStack/immutables"
-SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/mypy/d' tests/conftest.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # force running from BUILD_DIR to get the C extension tested
- cp -r tests "${BUILD_DIR}"/lib || die
- cd "${BUILD_DIR}"/lib || die
- epytest tests --ignore tests/test_mypy.py
- rm -r tests || die
-}