summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-08-18 20:50:25 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-08-18 20:53:21 +0100
commitb0b38821930a1a2c2b31f105af5a17f51f213d93 (patch)
treebb371d7fd545bf3267baba29e437b82d6d6ea525
parentnet-im/poezio: add new package (diff)
downloadgentoo-b0b38821.tar.gz
gentoo-b0b38821.tar.bz2
gentoo-b0b38821.zip
net-im/dino: add new package
Based on work by Anthony Parsons <ant@flussence.eu> (flussence overlay). Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-im/dino/dino-9999.ebuild80
-rw-r--r--net-im/dino/metadata.xml17
2 files changed, 97 insertions, 0 deletions
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
new file mode 100644
index 000000000000..9b578c608889
--- /dev/null
+++ b/net-im/dino/dino-9999.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+VALA_MIN_API_VERSION="0.34"
+inherit cmake-utils gnome2-utils vala
+
+DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
+HOMEPAGE="https://dino.im"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+gnupg +http +omemo"
+
+MY_REPO_URI="https://github.com/dino/dino"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${MY_REPO_URI}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="${MY_REPO_URI}/archive/${PV}.tar.gz"
+fi
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libgee:0.8
+ net-libs/glib-networking
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ gnupg? ( app-crypt/gpgme:1 )
+ http? ( net-libs/libsoup:2.4 )
+ omemo? ( dev-libs/libgcrypt:0 )
+"
+DEPEND="
+ $(vala_depend)
+ ${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local disabled_plugins=(
+ $(usex gnupg "" "openpgp")
+ $(usex omemo "" "omemo")
+ $(usex http "" "http-files")
+ )
+ local mycmakeargs+=(
+ "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ )
+
+ if has test ${FEATURES}; then
+ mycmakeargs+=("-DBUILD_TESTS=yes")
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/xmpp-vala-test || die
+}
+
+update_caches() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ update_caches
+}
+
+pkg_postrm() {
+ update_caches
+}
diff --git a/net-im/dino/metadata.xml b/net-im/dino/metadata.xml
new file mode 100644
index 000000000000..c488bca606f2
--- /dev/null
+++ b/net-im/dino/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/dino/dino/issues</bugs-to>
+ <remote-id type="github">dino/dino</remote-id>
+ </upstream>
+ <use>
+ <flag name="gnupg">Enable OpenPGP encryption plugin</flag>
+ <flag name="http">Enable HTTP file upload plugin</flag>
+ <flag name="omemo">Enable OMEMO encryption plugin</flag>
+ </use>
+</pkgmetadata>