summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-12 09:44:07 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-12 14:13:46 +0200
commitb0b8ec0eb0812395514c4ff9f48448fe80ba651b (patch)
treeb01abea7bdc279375d0a06730ee223b94402de4e
parentdev-util/pycharm-community: remove old version (diff)
downloadgentoo-b0b8ec0eb0812395514c4ff9f48448fe80ba651b.tar.gz
gentoo-b0b8ec0eb0812395514c4ff9f48448fe80ba651b.tar.bz2
gentoo-b0b8ec0eb0812395514c4ff9f48448fe80ba651b.zip
dev-qt/qtlocation: Fix build with libcxx
Closes: https://bugs.gentoo.org/903575 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-missing-include.patch26
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.8.ebuild5
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-missing-include.patch b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-missing-include.patch
new file mode 100644
index 000000000000..9dabca5aa231
--- /dev/null
+++ b/dev-qt/qtlocation/files/qtlocation-5.15.8-mapboxgl-missing-include.patch
@@ -0,0 +1,26 @@
+From 5a07e1967dcc925d9def47accadae991436b9686 Mon Sep 17 00:00:00 2001
+From: Manuel Nickschas <sputnick@quassel-irc.org>
+Date: Tue, 11 Apr 2023 22:24:11 +0200
+Subject: [PATCH] Add missing include
+
+Fixes build with libcxx, see also:
+https://bugs.gentoo.org/903575
+---
+ include/mbgl/util/unique_any.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/3rdparty/mapbox-gl-native/include/mbgl/util/unique_any.hpp b/src/3rdparty/mapbox-gl-native/include/mbgl/util/unique_any.hpp
+index c7dc8b38ea..0fb25b8b4a 100644
+--- a/src/3rdparty/mapbox-gl-native/include/mbgl/util/unique_any.hpp
++++ b/src/3rdparty/mapbox-gl-native/include/mbgl/util/unique_any.hpp
+@@ -3,6 +3,7 @@
+ #include <typeinfo>
+ #include <type_traits>
+ #include <stdexcept>
++#include <utility>
+ namespace mbgl {
+ namespace util {
+
+--
+GitLab
+
diff --git a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
index a1ab77f7306e..5ed68b32837c 100644
--- a/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.15.8.ebuild
@@ -39,7 +39,10 @@ QT5_TARGET_SUBDIRS=(
src/plugins/geoservices
)
-PATCHES=( "${FILESDIR}/${P}-mapboxgl-gcc13.patch" ) # bug 885431
+PATCHES=(
+ "${FILESDIR}/${P}-mapboxgl-gcc13.patch" # bug 885431
+ "${FILESDIR}/${P}-mapboxgl-missing-include.patch" # bug 903575
+)
src_configure() {
# src/plugins/geoservices requires files that are only generated when