summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-22 21:52:57 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-03-30 20:53:42 -0700
commitb0c6076e0f64f1a8a798b1f7b2b74a180f7eb5e8 (patch)
tree21d5f31c87803c5c8c495ff1664b6a39ed36288d
parentsys-fs/zfs-kmod: rework live ebuild (diff)
downloadgentoo-b0c6076e0f64f1a8a798b1f7b2b74a180f7eb5e8.tar.gz
gentoo-b0c6076e0f64f1a8a798b1f7b2b74a180f7eb5e8.tar.bz2
gentoo-b0c6076e0f64f1a8a798b1f7b2b74a180f7eb5e8.zip
sys-fs/zfs: rework live ebuild
major rework bump eapi to 7 add multi-python pyzfs installation behind python useflag use provided systemd unit, since upstream systemd handling changed use upstream bash-completion (with local patch) fix sed->zed typo in postinst code Closes: https://bugs.gentoo.org/548856 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--sys-fs/zfs/files/bash-completion-sudo.patch35
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild185
2 files changed, 138 insertions, 82 deletions
diff --git a/sys-fs/zfs/files/bash-completion-sudo.patch b/sys-fs/zfs/files/bash-completion-sudo.patch
new file mode 100644
index 000000000000..8ae9d25d2761
--- /dev/null
+++ b/sys-fs/zfs/files/bash-completion-sudo.patch
@@ -0,0 +1,35 @@
+From 3829d0b867f6aa4bde8798147dee74a86435d12c Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Fri, 22 Mar 2019 22:04:40 -0700
+Subject: [PATCH] contrib/bash_completion.d/zfs: remove sudo reference
+
+---
+ contrib/bash_completion.d/zfs | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/contrib/bash_completion.d/zfs b/contrib/bash_completion.d/zfs
+index 914db43c..b1aded36 100644
+--- a/contrib/bash_completion.d/zfs
++++ b/contrib/bash_completion.d/zfs
+@@ -21,13 +21,13 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ # OTHER DEALINGS IN THE SOFTWARE.
+
+-if [[ -w /dev/zfs ]]; then
++#if [[ -w /dev/zfs ]]; then
+ __ZFS_CMD="zfs"
+ __ZPOOL_CMD="zpool"
+-else
+- __ZFS_CMD="sudo zfs"
+- __ZPOOL_CMD="sudo zpool"
+-fi
++#else
++# __ZFS_CMD="sudo zfs"
++# __ZPOOL_CMD="sudo zpool"
++#fi
+
+ __zfs_get_commands()
+ {
+--
+2.21.0
+
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 0d0c1cf5b262..bde2d9e06bc3 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -1,43 +1,61 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=7
-if [ ${PV} == "9999" ] ; then
- inherit git-r3 linux-mod
- AUTOTOOLS_AUTORECONF="1"
- EGIT_REPO_URI="https://github.com/zfsonlinux/${PN}.git"
-else
- SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${P}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-fi
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit autotools-utils bash-completion-r1 flag-o-matic linux-info python-r1 systemd toolchain-funcs udev
+inherit bash-completion-r1 flag-o-matic linux-info linux-mod distutils-r1 systemd toolchain-funcs udev
DESCRIPTION="Userland utilities for ZFS Linux kernel module"
HOMEPAGE="https://zfsonlinux.org/"
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+else
+ SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
LICENSE="BSD-2 CDDL MIT"
SLOT="0"
-IUSE="custom-cflags debug kernel-builtin +rootfs test-suite static-libs"
-RESTRICT="test"
+IUSE="custom-cflags debug kernel-builtin python +rootfs test-suite static-libs"
COMMON_DEPEND="
+ ${PYTHON_DEPS}
net-libs/libtirpc
sys-apps/util-linux[static-libs?]
sys-libs/zlib[static-libs(+)?]
virtual/awk
+ python? (
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ )
"
-DEPEND="${COMMON_DEPEND}
+
+BDEPEND="${COMMON_DEPEND}
virtual/pkgconfig
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
"
RDEPEND="${COMMON_DEPEND}
!=sys-apps/grep-2.13*
- !kernel-builtin? ( =sys-fs/zfs-kmod-${PV}* )
+ !kernel-builtin? ( ~sys-fs/zfs-kmod-${PV} )
!sys-fs/zfs-fuse
!prefix? ( virtual/udev )
+ sys-fs/udev-init-scripts
+ rootfs? (
+ app-arch/cpio
+ app-misc/pax-utils
+ !<sys-boot/grub-2.00-r2:2
+ !<sys-kernel/genkernel-3.5.1.1
+ !<sys-kernel/genkernel-next-67
+ !<sys-kernel/bliss-initramfs-7.1.0
+ !<sys-kernel/dracut-044-r1
+ )
test-suite? (
sys-apps/util-linux
sys-devel/bc
@@ -46,24 +64,22 @@ RDEPEND="${COMMON_DEPEND}
sys-fs/mdadm
sys-process/procps
virtual/modutils
- )
- rootfs? (
- app-arch/cpio
- app-misc/pax-utils
- !<sys-boot/grub-2.00-r2:2
- )
+ )
"
-AT_M4DIR="config"
-AUTOTOOLS_IN_SOURCE_BUILD="1"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/bash-completion-sudo.patch" )
pkg_setup() {
if use kernel_linux && use test-suite; then
linux-info_pkg_setup
+
if ! linux_config_exists; then
ewarn "Cannot check the linux kernel configuration."
else
- # recheck that we don't have usblp to collide with libusb
if use test-suite; then
if linux_chkconfig_present BLK_DEV_LOOP; then
eerror "The ZFS test suite requires loop device support enabled."
@@ -72,34 +88,38 @@ pkg_setup() {
eerror "in /usr/src/linux/.config or"
eerror " Device Drivers --->"
eerror " Block devices --->"
- eerror " [ ] Loopback device support"
+ eerror " [X] Loopback device support"
fi
fi
fi
fi
-
}
src_prepare() {
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+
# Update paths
sed -e "s|/sbin/lsmod|/bin/lsmod|" \
-e "s|/usr/bin/scsi-rescan|/usr/sbin/rescan-scsi-bus|" \
-e "s|/sbin/parted|/usr/sbin/parted|" \
- -i scripts/common.sh.in
+ -i scripts/common.sh.in || die
- if use kernel-builtin
- then
- einfo "kernel-builtin enabled, removing module loading from"
- einfo "systemd units."
- sed -i -e '/modprobe\ zfs/d' etc/systemd/system/*.service.in || die
+ if use python; then
+ pushd contrib/pyzfs >/dev/null || die
+ distutils-r1_src_prepare
+ popd >/dev/null || die
fi
- autotools-utils_src_prepare
}
src_configure() {
use custom-cflags || strip-flags
- local myeconfargs=(
+
+ local myconf=(
--bindir="${EPREFIX}/bin"
+ --enable-systemd
+ --enable-sysvinit
--sbindir="${EPREFIX}/sbin"
--with-config=user
--with-dracutdir="${EPREFIX}/usr/lib/dracut"
@@ -109,47 +129,53 @@ src_configure() {
--with-systemdunitdir="$(systemd_get_systemunitdir)"
--with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
$(use_enable debug)
+ $(use_enable python pyzfs)
)
- autotools-utils_src_configure
-
- # prepare systemd unit and helper script
- cat "${FILESDIR}/zfs.service.in" | \
- sed -e "s:@sbindir@:${EPREFIX}/sbin:g" \
- -e "s:@sysconfdir@:${EPREFIX}/etc:g" \
- > "${T}/zfs.service" || die
- cat "${FILESDIR}/zfs-init.sh.in" | \
- sed -e "s:@sbindir@:${EPREFIX}/sbin:g" \
- -e "s:@sysconfdir@:${EPREFIX}/etc:g" \
- > "${T}/zfs-init.sh" || die
- if use kernel-builtin
- then
- sed -i -e '/modprobe\ zfs/d' "${T}/zfs.service" || die
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ if use python; then
+ pushd contrib/pyzfs >/dev/null || die
+ distutils-r1_src_compile
+ popd >/dev/null || die
fi
}
src_install() {
- autotools-utils_src_install
+ default
+
gen_usr_ldscript -a uutil nvpair zpool zfs zfs_core
- use test-suite || rm -rf "${ED}usr/share/zfs"
- newbashcomp "${FILESDIR}/bash-completion-r1" zfs
+ use test-suite || rm -rf "${ED}/usr/share/zfs"
+
+ dobashcomp contrib/bash_completion.d/zfs
bashcomp_alias zfs zpool
- exeinto /usr/libexec
- doexe "${T}/zfs-init.sh"
- systemd_dounit "${T}/zfs.service"
+ # strip executable bit from conf.d file
+ fperms 0644 /etc/conf.d/zfs
+
+ if use python; then
+ pushd contrib/pyzfs >/dev/null || die
+ distutils-r1_src_install
+ popd >/dev/null || die
+ fi
+
+ # enforce best available python implementation
+ python_setup
+ python_fix_shebang "${ED}/bin"
}
pkg_postinst() {
- if ! use kernel-builtin && [ ${PV} = "9999" ]
- then
+ if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then
einfo "Adding ${P} to the module database to ensure that the"
einfo "kernel modules and userland utilities stay in sync."
update_moduledb
fi
- if [ -e "${EROOT}etc/runlevels/boot/zfs" ]
- then
+ if [[ -e "${EROOT}/etc/runlevels/boot/zfs" ]]; then
einfo 'The zfs boot script has been split into the zfs-import,'
einfo 'zfs-mount and zfs-share scripts.'
einfo
@@ -159,24 +185,23 @@ pkg_postinst() {
einfo 'The zfs-import and zfs-mount scripts have been added to the boot'
einfo 'runlevel while the zfs-share script is in the default runlevel.'
- rm "${EROOT}etc/runlevels/boot/zfs"
- ln -snf "${EROOT}etc/init.d/zfs-import" \
- "${EROOT}etc/runlevels/boot/zfs-import"
- ln -snf "${EROOT}etc/init.d/zfs-mount" \
- "${EROOT}etc/runlevels/boot/zfs-mount"
- ln -snf "${EROOT}etc/init.d/zfs-share" \
- "${EROOT}etc/runlevels/default/zfs-share"
+ rm "${EROOT}/etc/runlevels/boot/zfs"
+ ln -snf "${EROOT}/etc/init.d/zfs-import" \
+ "${EROOT}/etc/runlevels/boot/zfs-import"
+ ln -snf "${EROOT}/etc/init.d/zfs-mount" \
+ "${EROOT}/etc/runlevels/boot/zfs-mount"
+ ln -snf "${EROOT}/etc/init.d/zfs-share" \
+ "${EROOT}/etc/runlevels/default/zfs-share"
else
- [ -e "${EROOT}etc/runlevels/boot/zfs-import" ] || \
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
einfo "You should add zfs-import to the boot runlevel."
- [ -e "${EROOT}etc/runlevels/boot/zfs-mount" ] || \
+ [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
einfo "You should add zfs-mount to the boot runlevel."
- [ -e "${EROOT}etc/runlevels/default/zfs-share" ] || \
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
einfo "You should add zfs-share to the default runlevel."
fi
- if [ -e "${EROOT}etc/runlevels/default/zed" ]
- then
+ if [[ -e "${EROOT}/etc/runlevels/default/zed" ]]; then
einfo 'The downstream OpenRC zed script has replaced by the upstream'
einfo 'OpenRC zfs-zed script.'
einfo
@@ -184,18 +209,17 @@ pkg_postinst() {
einfo 'convenience, it has been automatically removed and the zfs-zed'
einfo 'script that replaced it has been configured to start.'
- rm "${EROOT}etc/runlevels/boot/zed"
- ln -snf "${EROOT}etc/init.d/zfs-sed" \
- "${EROOT}etc/runlevels/default/zfs-zed"
+ rm "${EROOT}/etc/runlevels/boot/zed"
+ ln -snf "${EROOT}/etc/init.d/zfs-zed" \
+ "${EROOT}/etc/runlevels/default/zfs-zed"
else
- [ -e "${EROOT}etc/runlevels/default/zfs-zed" ] || \
+ [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
einfo "You should add zfs-zed to the default runlevel."
fi
- if [ -e "${EROOT}etc/runlevels/shutdown/zfs-shutdown" ]
- then
+ if [[ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ]]; then
einfo "The zfs-shutdown script is obsolete. Removing it from runlevel."
- rm "${EROOT}etc/runlevels/shutdown/zfs-shutdown"
+ rm "${EROOT}/etc/runlevels/shutdown/zfs-shutdown"
fi
systemd_reenable zfs-zed.service
@@ -205,13 +229,10 @@ pkg_postinst() {
systemd_reenable zfs-share.service
systemd_reenable zfs-import.target
systemd_reenable zfs.target
- systemd_reenable zfs.service
-
}
pkg_postrm() {
- if ! use kernel-builtin && [ ${PV} = "9999" ]
- then
+ if ! use kernel-builtin && [[ ${PV} == "9999" ]]; then
remove_moduledb
fi
}