summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-28 16:32:34 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-28 16:32:34 +0200
commitb0d403ffa033acba47631a0e345ada2ae9015958 (patch)
tree74babb8e201af26cbe2b0d7b639cb1e2d918c647
parentapp-admin/hcloud: version bump to 1.30.0 (diff)
downloadgentoo-b0d403ff.tar.gz
gentoo-b0d403ff.tar.bz2
gentoo-b0d403ff.zip
www-apache/mod_perl: update EAPI 5 -> 7
Closes: https://bugs.gentoo.org/828739 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch4
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch4
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.11-r1.ebuild (renamed from www-apache/mod_perl/mod_perl-2.0.11.ebuild)13
3 files changed, 12 insertions, 9 deletions
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch b/www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch
index 0930278aeba3..40c88c83eb87 100644
--- a/www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch
+++ b/www-apache/mod_perl/files/mod_perl-2.0.1-sneak-tmpdir.patch
@@ -1,5 +1,5 @@
---- t/conf/modperl_extra.pl.orig 2005-05-16 18:27:45.000000000 +1000
-+++ t/conf/modperl_extra.pl 2005-05-16 18:34:46.000000000 +1000
+--- a/t/conf/modperl_extra.pl
++++ b/t/conf/modperl_extra.pl
@@ -136,6 +136,8 @@
sub test_modperl_env {
# see t/response/TestModperl/env.pm
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch b/www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch
index c6c5bed4ed0c..77db5f65263d 100644
--- a/www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch
+++ b/www-apache/mod_perl/files/mod_perl-2.0.11-perl534.patch
@@ -4,8 +4,8 @@ Fix build for perl >= 5.33.7
Patch by Leon Timmermans <fawaka@gmail.com> from https://github.com/Perl/perl5/issues/18617
---- perl/modperl/trunk/src/modules/perl/modperl_perl.c 2021/04/20 13:48:02 1889013
-+++ perl/modperl/trunk/src/modules/perl/modperl_perl.c 2021/04/20 13:55:29 1889014
+--- a/src/modules/perl/modperl_perl.c
++++ b/src/modules/perl/modperl_perl.c
@@ -268,7 +268,7 @@
#ifdef MP_NEED_HASH_SEED_FIXUP
if (MP_init_hash_seed_set) {
diff --git a/www-apache/mod_perl/mod_perl-2.0.11.ebuild b/www-apache/mod_perl/mod_perl-2.0.11-r1.ebuild
index 77fb5135e3a3..3b0cc28a4471 100644
--- a/www-apache/mod_perl/mod_perl-2.0.11.ebuild
+++ b/www-apache/mod_perl/mod_perl-2.0.11-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit depend.apache apache-module perl-module eutils
+inherit depend.apache apache-module perl-module
DESCRIPTION="An embedded Perl interpreter for Apache2"
HOMEPAGE="https://perl.apache.org/ https://projects.apache.org/project.html?perl-mod_perl"
@@ -15,7 +15,7 @@ KEYWORDS="amd64 ~arm ppc ppc64 x86"
IUSE="debug ithreads test"
RESTRICT="!test? ( test )"
-SRC_TEST=do
+DIST_TEST=do
# Apache::Reload, Apache::SizeLimit, and Apache::Test are force-unbundled.
# The minimum versions requested here are the bundled versions.
@@ -73,6 +73,8 @@ src_prepare() {
}
src_configure() {
+ _init_apache2_late
+
local debug=$(usex debug 1 0)
local nothreads=$(usex ithreads 0 1)
myconf=(
@@ -108,7 +110,8 @@ src_install() {
default
perl_delete_localpod
- perl_delete_packlist
+ perl_fix_packlist
+ perl_delete_emptybsdir
insinto "${APACHE_MODULES_CONFDIR}"
doins "${FILESDIR}"/2.0.3/apache2-mod_perl-startup.pl