summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 17:15:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 17:15:45 +0100
commitb0d7b854a8dc8908adee7c6dba30ceee6a4b8c03 (patch)
tree5b743a8ea0385c4dce5b42c7efa19657c50a94fc
parentxfce-base/garcon: Bump to 4.17.2 (diff)
downloadgentoo-b0d7b854.tar.gz
gentoo-b0d7b854.tar.bz2
gentoo-b0d7b854.zip
xfce-base/libxfce4ui: Bump to 4.17.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.17.8.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 85550ae54901..565538775202 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.16.1.tar.bz2 785811 BLAKE2B d1267b328b7e2d07bfe85ce320da6a60d5a7d739c5ded9b213b83b0cde2061d3badc937e71c4353291ed435fb9d1294cadcc99402cdae69f4bcecf412dd525f2 SHA512 c183bbc75539c777fe704d0a1c4e533fdd2efb6cbc980cfedc2eaa80d0e6223db038498774ffcdc720d7f991dd8d9634183a757a4c4d1728cc9956a33cb187d0
DIST libxfce4ui-4.17.7.tar.bz2 893700 BLAKE2B 16b6aa20e510ef5661e1d0e172864ae00826bae7ba2b777b0160a7a5760b30b70891bb08ec78d32875580cdc4118ee7e89d6b3ee2dfd60a8ea73b61a4b4199a2 SHA512 e8d339fa266e637bc9b16095c65cc75239f7f6cb2bdc93c9453ec6bc5d47018e81b3aa96fac4ae89545d059ce3de62951d358429e874ffede75f99ac9d80ba2d
+DIST libxfce4ui-4.17.8.tar.bz2 893977 BLAKE2B 7a17a310095e973798db98cc74d82f49dda7e769015e27a00bfdc02111ff45a3a21c64e3c0a39bc308aebc71ff0782ace98c8ec244edb689721b352d1e0c05ef SHA512 b2b345f36590cfad6f2b8d02cc7b3e3254900bff2dde5164617b82e4339e6a73940958cd66a4ef594c2ff1e594d3d9d09a5b9cc6e76aa005cd472848552e7e53
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.17.8.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.17.8.ebuild
new file mode 100644
index 000000000000..0fb1236d5c41
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.17.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}