summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-10-25 12:47:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-10-25 12:47:13 -0500
commitb0e1db50db65c294e2b175c6d79b7111454a7101 (patch)
treeca9e8127887947fe8417441d5db3e81d59ad2ea0
parentapp-misc/nnn: Version bump (v2.0) (diff)
downloadgentoo-b0e1db50.tar.gz
gentoo-b0e1db50.tar.bz2
gentoo-b0e1db50.zip
app-admin/puppet-agent: 6.0.3 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.0.3.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index a21fcb81b54b..8b2de5b281da 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -6,3 +6,5 @@ DIST puppet-agent_5.5.7-1stretch_amd64.deb 17300432 BLAKE2B 4c3b13361b9a97734a7b
DIST puppet-agent_5.5.7-1stretch_i386.deb 18222282 BLAKE2B b9ce9269cc59d79450cb66c9c3e545ad4267ad1a43905df4ca57b45ad1213dd11c9ddcffb77719a151f52eb60d6792a486823ea4a29b2f4e83a2d62960c9691a SHA512 b65ecaf27c2bcc6556d7d43a0b78e282a64c72eed3b672af5d2e23c34eefe8134b6d4c60505f9d7c6e5b40ed4a1ad391128933c27710819f5078ec7d8680b6d4
DIST puppet-agent_6.0.2-1stretch_amd64.deb 17859762 BLAKE2B c787eb36bc1eacb544b669959d83539ba157702627a7cf925cd1be9e919604cd749f86a1635e9c0b53fe85f446e377fc61123ca259357f4a5781d0f8f406f365 SHA512 c0587cbf382258c73760837eab85985c2414ff59521bbed680b13b5d09ebb76a96cc52e553d68fb482f4b2d725b130fc3b747849637b4c73cb11b5f5cd266a44
DIST puppet-agent_6.0.2-1stretch_i386.deb 18596344 BLAKE2B 9f1f99e0c1033f621b3c50674f18e296e65b9addf82e61163e995f69eedbca97174a3ede6324e9bec1b46c4819a2c68892a4bdb7db8e81aba975bb6293c018df SHA512 9f2fc097ea2ef7c4411227ba97fa3371b98b3b3b4fb5e9c70a71ae87215e3c7b9fb5ee2cd58324bb24fb2352e34d4509165ca8e2c9c1144e89237307683a7dfd
+DIST puppet-agent_6.0.3-1stretch_amd64.deb 17876404 BLAKE2B 06f4a951270b96e93ff72c5e0e1deb8c2e21588a424e06d9619397586d2c92367debab0d552df0c88bd2ccc53644c53b1117f2826d01e2feeab94934505e3700 SHA512 1dfbd1a9266f0d092d71071e9d6c271e2ca9ff6a8457699a9561a8f5ad2be05ef779f80d5dac3dbe3744dad30b66bd98dd593ca7e7f2696183eb30edb430bf4c
+DIST puppet-agent_6.0.3-1stretch_i386.deb 18615216 BLAKE2B 8fd3e6344fd9773dae7bc1bd94543cfbe7f71158423b00aac01be4c3e911c6576ea159fc5cbf88ff5342e8b7e13d14fa23524771b33688ac828b40df508bd613 SHA512 9aea3b90693a566fe9f285da60772f739c07d7cc40abaa6a98bc0e4d2d2eba1178c01a6e8d4b2a48b6f0009d3bef8434412b2eeb5876966249fd872ef8bda159
diff --git a/app-admin/puppet-agent/puppet-agent-6.0.3.ebuild b/app-admin/puppet-agent/puppet-agent-6.0.3.ebuild
new file mode 100644
index 000000000000..4ad0513947d9
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.0.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ sys-libs/readline:0/7
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}