summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:05:01 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:38:20 +0300
commitb0e640181329521f2e1c855443c8cec93bb5ca85 (patch)
treec69ea495df6794a375623485916ed7b79d9de0d7
parentdev-python/botocore: add 1.27.70 (diff)
downloadgentoo-b0e64018.tar.gz
gentoo-b0e64018.tar.bz2
gentoo-b0e64018.zip
dev-python/boto3: add 1.24.70
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.70.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8fe14585bd2b..d5233a283fe6 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.24.64.gh.tar.gz 533638 BLAKE2B 1cf4774e17226b453aec3203eea6f343e092
DIST boto3-1.24.65.gh.tar.gz 533830 BLAKE2B 10ff261500c010449f281bdd6c2767910519026b8e6a9ef93a36a2d6c9fdb39b1d8b15585a3eae615d96a8b19c63c9eecd88a8c08dca974ff5b233933bb72fdd SHA512 588426a35b4764d05434593538afb245fbfb9e1626e0f0fc86741e83c9662331930bfd4e267f132a01742304bbf70fc71998b61146bee4e215600d6ac26a7afa
DIST boto3-1.24.66.gh.tar.gz 534375 BLAKE2B 3a922be7a1736af8d37a11b62f444601e8e822b2ccb937e2e295332a102abd3def304a80c432664504f81bbf1a95aad635226073ad93c194ff96a99ad4ad60d4 SHA512 ae11b8a5247f7a9ad2c222e5e52bae27e7686ad2228e815e9c5f755ec57d1d3e2f805b6f4875edc791dfd4e783f80e0045ca34ceb2cf3dfd5831a086d9a8eb20
DIST boto3-1.24.69.gh.tar.gz 536008 BLAKE2B 2a7c031423bac668110c0fdc17c66085c81cf79646c4b8c4e7442a5451cbb9b828208ebfff576d4b50e9e9ca763af1b78631be5bb6126b20b2497e98982e674b SHA512 b6529bc1a73816057bfb900b29f72cd20bdd828c033137c4280cec20d174bf3d27fbf48333672a6e9d5481ca0b70ac6b2ae7fc11a7a8b0e773cc1df7ae63c491
+DIST boto3-1.24.70.gh.tar.gz 536364 BLAKE2B b93c882f93093e453c82ea0cea298ccaeb9159271b8fc933bc884f1cc2fae14131a28cacfecf0c0f931c77d03d92acdac23a16acbdf4ceb1da0dca6859048616 SHA512 d7fbf4fdf44adf723d1325cb80c44c3e78df4d8c30b106d8256cdaf39bab442498c40624e2d9fb8f53af278518bb897bb9b2b040552f5420a82914f9083ec6bf
diff --git a/dev-python/boto3/boto3-1.24.70.ebuild b/dev-python/boto3/boto3-1.24.70.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.70.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}