summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-30 19:54:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-30 19:58:54 +0300
commitb0e84cab8d77bd0494bdf6847897ab69872874cd (patch)
tree6dbc9545bf958dea6adf5a4c315640c818b621a0
parentnet-dns/libidn2: add USE=nls (diff)
downloadgentoo-b0e84cab.tar.gz
gentoo-b0e84cab.tar.bz2
gentoo-b0e84cab.zip
dev-python/rdflib: drop 6.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/rdflib/Manifest1
-rw-r--r--dev-python/rdflib/rdflib-6.1.1.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index a42b874888dc..2e463c1f67d3 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1,2 +1 @@
-DIST rdflib-6.1.1.tar.gz 1587670 BLAKE2B f13831124a8f292f0481f5ee9995b6b7ba82992cbe51abb0067703b2acee9f13ce5a62379636ac9f36823afa5b841799c1f26358efb6c12eca2df333611d5488 SHA512 049608dc37dba929eac1e40431885d319311f27be9fddc292d768e3703927e61a646a73137e4a1eaa16836cfba4606ea2cfd8fe3a86cfbf10e3271cee2ee251f
DIST rdflib-6.2.0.gh.tar.gz 4886953 BLAKE2B 74044b0cbaf6c1ba6f2a43347112118dcf92b5237afdd49782ca6d637df092379ff2d81eaec254ad0bf25057f8c0cd44c82a35a89d4ce7b21c8e222de9aef16a SHA512 8177c50e9c2d48859a061dfee24c3560b8f979bc306b3d940a9251ec130e3a324bbad474f4fa7ced5e11522d3bd4e13931461bf106f31177fd972806968d8245
diff --git a/dev-python/rdflib/rdflib-6.1.1.ebuild b/dev-python/rdflib/rdflib-6.1.1.ebuild
deleted file mode 100644
index ce98ab1a025b..000000000000
--- a/dev-python/rdflib/rdflib-6.1.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite?,threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1 optfeature
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.org/project/rdflib/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="examples sqlite"
-
-RDEPEND="
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/berkeleydb[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-EPYTEST_IGNORE=(
- # Uses network
- test/test_so_69984830.py
-)
-
-python_prepare_all() {
- # these tests require internet access
- sed -e '/doctest/d' -i setup.cfg || die
- rm test/{test_sparql_service.py,test_graph.py,jsonld/test_onedotone.py} || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- optfeature "support for sys-libs/db (Berkeley DB for MySQL)" dev-python/berkeleydb
-}