summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-09 20:38:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-09 20:38:17 +0300
commitb1353ca9973df18767968e2619c9fc6863426586 (patch)
tree2bf90ff00196631c57d12f40e70b8f1bfb62076f
parentapp-text/sigil: fix qt5 qt6 USE flags (diff)
downloadgentoo-b1353ca9973df18767968e2619c9fc6863426586.tar.gz
gentoo-b1353ca9973df18767968e2619c9fc6863426586.tar.bz2
gentoo-b1353ca9973df18767968e2619c9fc6863426586.zip
app-editors/featherpad: fix qt5 qt6 USE flags
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-editors/featherpad/featherpad-1.4.1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-editors/featherpad/featherpad-1.4.1.ebuild b/app-editors/featherpad/featherpad-1.4.1.ebuild
index 69a1e0841b09..f39d1be78c82 100644
--- a/app-editors/featherpad/featherpad-1.4.1.ebuild
+++ b/app-editors/featherpad/featherpad-1.4.1.ebuild
@@ -13,12 +13,11 @@ S="${WORKDIR}/FeatherPad-${PV}"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="+qt5 qt6 +X"
-REQUIRED_USE="^^ ( qt5 qt6 )"
+IUSE="qt6 +X"
RDEPEND="
app-text/hunspell:=
- qt5? (
+ !qt6? (
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
@@ -37,14 +36,14 @@ DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
BDEPEND="
- qt5? ( dev-qt/linguist-tools:5 )
+ !qt6? ( dev-qt/linguist-tools:5 )
qt6? ( dev-qt/qttools:6[linguist] )
"
src_configure() {
local mycmakeargs=(
-DWITHOUT_X11=$(usex !X)
- -DENABLE_QT5=$(usex qt5)
+ -DENABLE_QT5=$(usex !qt6)
)
cmake_src_configure
}