summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-26 07:48:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-26 08:10:14 +0100
commitb13b88159a1efde98818dad04b9d055cd32d9889 (patch)
tree0a0bf33aff650dc32ed392d063af0887bfb6a2c9
parentdev-python/huawei-lte-api: Bump to 1.6.10 (diff)
downloadgentoo-b13b8815.tar.gz
gentoo-b13b8815.tar.bz2
gentoo-b13b8815.zip
dev-python/Levenshtein: Bump to 0.20.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.20.9.ebuild45
-rw-r--r--dev-python/Levenshtein/Manifest1
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.20.9.ebuild b/dev-python/Levenshtein/Levenshtein-0.20.9.ebuild
new file mode 100644
index 000000000000..7db2901fb1af
--- /dev/null
+++ b/dev-python/Levenshtein/Levenshtein-0.20.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://pypi.org/project/Levenshtein/
+ https://github.com/maxbachmann/Levenshtein/
+"
+SRC_URI="
+ https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-cpp/rapidfuzz-cpp-1.7.0
+"
+RDEPEND="
+ <dev-python/rapidfuzz-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/Levenshtein/Manifest b/dev-python/Levenshtein/Manifest
index 499ea375e802..5c48d7380720 100644
--- a/dev-python/Levenshtein/Manifest
+++ b/dev-python/Levenshtein/Manifest
@@ -1,2 +1,3 @@
DIST Levenshtein-0.20.8.gh.tar.gz 36607 BLAKE2B 8c35c47768a21651c7922151f9a4ba24782106fee1cc2eada2b81924b3e340aa929ec8b9944a7ea9cfaf8934da49cc377849e599fedebb6187afdfd486e8b9f4 SHA512 3a248b5d1a18c8afeffaa637c831b07266dd36a094b713c18b7182a49de7df9a3b7316d00e9329e2ae49f92c601e32a61590338e30a7e4f33ffe0d76c6219061
+DIST Levenshtein-0.20.9.gh.tar.gz 36617 BLAKE2B 8e995f1c1648c81bea20844f7afc3c5dddd7dc31e5b6fc99a96930130c7f85bb32c4c4c85b319149d8511f6591ede96098038ea1b502a3e33a42ca3d21db4e2a SHA512 1d5dccd33ae8bd19b234861435212c7a57ba330a5f76a45c9e5b8ac3e401bc3d5eb3c72aea20e66bf0ebaaa6b760131dfef07fb5a2cf4d7191b595e1d962d93c
DIST python-Levenshtein-0.12.2.tar.gz 50502 BLAKE2B d8992d30639e36aac1b85fada8f5273ed867aa3019208ffeb9972e999dad783d4ee16e1f6988c9306eb80f622b61fcf3a0a937b380c7a5acf50223268ed8de1d SHA512 97eac9d19121758af7620ad3963846e48434ceabb5376a83f28452015adf1a620620bfb53edb1c4f60b0fc8ec2b0faf35a105d7e2a0fc5df7a45fce81ba0dcdb