summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-07-06 06:35:06 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-06 06:35:06 +0200
commitb141f7f535e3369fbdaaff3ba84c868eb5b17e70 (patch)
tree83985c47171e871b522fc882c03ad30cb5189ead
parentmedia-libs/liblscp: bump to 0.9.4 (diff)
downloadgentoo-b141f7f535e3369fbdaaff3ba84c868eb5b17e70.tar.gz
gentoo-b141f7f535e3369fbdaaff3ba84c868eb5b17e70.tar.bz2
gentoo-b141f7f535e3369fbdaaff3ba84c868eb5b17e70.zip
media-sound/qsynth: bump to 0.9.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.9.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 6b75a2087556..4d84a27ed381 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.9.3.tar.gz 395265 BLAKE2B c19154ba02680ae784ea016bbcb2dcd6c3517d6e810d76cc16919508e2e7310d23a8e8397f45340c138f018340525ecae8d941ce5acf5d4e16295e88d3450069 SHA512 7da5bc0fd8feed6b3b0b048e7ac3fa86937d82ff34528fd0dbb1dd5a05fbff2bb2d8e360e499325660172acec7216964ce1442b75afc10ab0647b91376b2c421
+DIST qsynth-0.9.4.tar.gz 395550 BLAKE2B e25195755c52c63912b03a416878d248712b78ba0014414bc8b1d31cbd5bb75562640de4a0255d2727a40274a6ff3a84b201d39c93674140ff31ccc581bfd254 SHA512 764a90fd86451cd3a12c71f061f4a603cdce54ae80e6543d05fa66a97ea0b7c50bac0350f01f597ec93ed445a5433a9dea6d9c5a43ce385c231aaea8e13675d4
diff --git a/media-sound/qsynth/qsynth-0.9.4.ebuild b/media-sound/qsynth/qsynth-0.9.4.ebuild
new file mode 100644
index 000000000000..59c6e5666ca2
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop qmake-utils xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.1-cmake-no-git-version.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}