summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-30 07:36:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-30 08:08:18 +0100
commitb15254ba9956c3fcec46f6ca0240218c902f53c1 (patch)
tree5622cc5ec1f44b5de1bb71ec915bdcd14a856d5a
parentdev-python/pydantic: Bump to 1.10.3 (diff)
downloadgentoo-b15254ba.tar.gz
gentoo-b15254ba.tar.bz2
gentoo-b15254ba.zip
dev-python/pyrsistent: Bump to 0.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyrsistent/Manifest1
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.19.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/Manifest b/dev-python/pyrsistent/Manifest
index 737bde1a1536..26740ccbcbc7 100644
--- a/dev-python/pyrsistent/Manifest
+++ b/dev-python/pyrsistent/Manifest
@@ -1 +1,2 @@
DIST pyrsistent-0.19.2.tar.gz 102438 BLAKE2B aa231a7c300d2f1501abdf2fc74dfa9672ad8000d87e3fa9beaa51aff4816dad4f142e9a2e609dee402352cf5a0477b6d4dc31460a71e7d98a592604fcaa97d6 SHA512 fdaadb65e72db4f90ecb1526fd68eb2b60b278071978d4b5a1b1379be83c60d30fd653dd7e6527c217d4e50f05c7d641290172aa5d5e4741dfe5e08f0b0c282b
+DIST pyrsistent-0.19.3.tar.gz 102640 BLAKE2B 60c5ef9d3f26c4529d05804df13453c75b6ff70e12fbbbbe22312686da929766fc903b18ca77d626192e1f3fc9fbdfdbbbd4eef102f1504b38feeeedf00450d5 SHA512 6bb70b6fd65b5cd9f961a3199c2d90725aaa66fb869e4eba2143735e2f3a7e4ecdc782b3498acc2d92e263c3bed14cec8cc77324f4ebd08c300ba6735db5ecf7
diff --git a/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild b/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild
new file mode 100644
index 000000000000..7a4e9ef1fc6d
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.19.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="
+ https://github.com/tobgu/pyrsistent/
+ https://pypi.org/project/pyrsistent/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest