summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-07-24 19:33:31 +0300
committerMichał Górny <mgorny@gentoo.org>2023-07-24 20:48:54 +0200
commitb15549cdf302fa090e9ff31f8cad5adb08c64805 (patch)
tree3560d577e20df18789bdff12c00cf963475a2b41
parentdev-python/elasticsearch-py: disable server tests (diff)
downloadgentoo-b15549cd.tar.gz
gentoo-b15549cd.tar.bz2
gentoo-b15549cd.zip
dev-python/elasticsearch-py: Prepare for rename
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-8.7.0.ebuild5
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-8.8.0.ebuild5
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-8.8.2.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-8.7.0.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-8.7.0.ebuild
index 776a587df4d5..ad2335144a0b 100644
--- a/dev-python/elasticsearch-py/elasticsearch-py-8.7.0.ebuild
+++ b/dev-python/elasticsearch-py/elasticsearch-py-8.7.0.ebuild
@@ -7,13 +7,16 @@ DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
+MY_P="elasticsearch-py-${PV}"
+
DESCRIPTION="Official Elasticsearch client library for Python"
HOMEPAGE="
https://ela.st/es-python
https://github.com/elastic/elasticsearch-py
https://pypi.org/project/elasticsearch/
"
-SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="Apache-2.0"
SLOT="0/$(ver_cut 1)"
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-8.8.0.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-8.8.0.ebuild
index c20e136a45d5..458d7cf0a7a8 100644
--- a/dev-python/elasticsearch-py/elasticsearch-py-8.8.0.ebuild
+++ b/dev-python/elasticsearch-py/elasticsearch-py-8.8.0.ebuild
@@ -7,13 +7,16 @@ DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
+MY_P="elasticsearch-py-${PV}"
+
DESCRIPTION="Official Elasticsearch client library for Python"
HOMEPAGE="
https://ela.st/es-python
https://github.com/elastic/elasticsearch-py
https://pypi.org/project/elasticsearch/
"
-SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="Apache-2.0"
SLOT="0/$(ver_cut 1)"
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-8.8.2.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-8.8.2.ebuild
index 8f773022672b..8bf92575456d 100644
--- a/dev-python/elasticsearch-py/elasticsearch-py-8.8.2.ebuild
+++ b/dev-python/elasticsearch-py/elasticsearch-py-8.8.2.ebuild
@@ -7,13 +7,16 @@ DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
+MY_P="elasticsearch-py-${PV}"
+
DESCRIPTION="Official Elasticsearch client library for Python"
HOMEPAGE="
https://ela.st/es-python
https://github.com/elastic/elasticsearch-py
https://pypi.org/project/elasticsearch/
"
-SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="Apache-2.0"
SLOT="0/$(ver_cut 1)"