summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2019-01-09 14:24:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-03 20:13:47 +0100
commitb1699a0a21d6b5ad39a582517e00c98a82b802e3 (patch)
tree6179011f7cd3a9c43b25f6d3874e02357f4f4dc4
parentapp-text/pdfgrep: Correct remote-id to 'gitlab' in metadata.xml (diff)
downloadgentoo-b1699a0a.tar.gz
gentoo-b1699a0a.tar.bz2
gentoo-b1699a0a.zip
app-text/pdfgrep: Bump to 2.1.2
Closes: https://bugs.gentoo.org/655510 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/pdfgrep/Manifest1
-rw-r--r--app-text/pdfgrep/pdfgrep-2.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-text/pdfgrep/Manifest b/app-text/pdfgrep/Manifest
index cbccbe4a7348..23af45ba4367 100644
--- a/app-text/pdfgrep/Manifest
+++ b/app-text/pdfgrep/Manifest
@@ -1,2 +1,3 @@
DIST pdfgrep-1.4.1.tar.gz 151926 BLAKE2B 68b846b26c28e8209fa3ac7a7e6fe3d0c4c6a298e9bea2e3929fd82a44482ec914bd3594f3e07da8c56766e94ca3d4c3c2d6997364393e95b3741b1bf9685ec5 SHA512 27ce23c25a5f284b3eba92a0f8dbf02600248548967c1e71dfb41e43528824d9add587ea0ac23899ff07d2ffc6c74c2e6e4c2e7240e69494b8d31b7a4afc3735
DIST pdfgrep-2.0.1.tar.gz 187217 BLAKE2B f498158e63e2f8419829df0d1801a31d3dff02627ccf0efee7239650203300233d1a19a5c72c57eb24495f2b5403e0e2c6a479b0f28a8d053aa578c732866b1a SHA512 4285f8cb514975a0040cdd6b82133090e27ba5c2f95ca880dccc3dd4fa3427260a5fc73d807df9124a79fa36ac6ed8c11380cde11e00599ed7134d92c50df4a0
+DIST pdfgrep-2.1.2.tar.gz 197289 BLAKE2B 94d20649104f7b17adf2d99bdf2ce215cf16746c649f7ec77d58a41b90b13dd903d47b5ed2d35f56ca7ca12ae49cfb8a57004f9ad3ee6b8930f533b33d7d8463 SHA512 27bc4741e5203b2fd265815a22ad8d702b3455b2ae932641b040fc9ce615bc9ff0abef221eb2ec8aa59c79cb139d31184261d076f9731177129a473d62aa4e5c
diff --git a/app-text/pdfgrep/pdfgrep-2.1.2.ebuild b/app-text/pdfgrep/pdfgrep-2.1.2.ebuild
new file mode 100644
index 000000000000..41a8ff10f22f
--- /dev/null
+++ b/app-text/pdfgrep/pdfgrep-2.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A tool similar to grep which searches text in PDFs"
+HOMEPAGE="https://pdfgrep.org/"
+SRC_URI="https://www.pdfgrep.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pcre test unac"
+
+RDEPEND="
+ app-text/poppler:=[cxx]
+ dev-libs/libgcrypt:0=
+ pcre? ( dev-libs/libpcre[cxx] )
+ unac? ( app-text/unac )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ test? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexrecommended
+ dev-util/dejagnu
+ )"
+
+DOCS="AUTHORS README.md NEWS.md"
+
+src_configure() {
+ econf \
+ $(use_with pcre libpcre) \
+ $(use_with unac)
+}