summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:23:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:44:37 -0500
commitb16cc962ece1e2f07ec96bd501a90ca531efb7cc (patch)
treea88b3c913422e058da251ba855846b905e85cfd3
parentdev-python/oslo-cache: 1.30.3 bump (diff)
downloadgentoo-b16cc962.tar.gz
gentoo-b16cc962.tar.bz2
gentoo-b16cc962.zip
dev-python/os-brick: 2.5.5 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/os-brick/Manifest1
-rw-r--r--dev-python/os-brick/os-brick-2.5.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/os-brick/Manifest b/dev-python/os-brick/Manifest
index fac5703ae1dd..d48a89c1e5ae 100644
--- a/dev-python/os-brick/Manifest
+++ b/dev-python/os-brick/Manifest
@@ -1 +1,2 @@
DIST os-brick-2.5.4.tar.gz 173675 BLAKE2B 9e1906f718b79ed3b0b332864fc6263af7d3c9ef0da2d93b2b099e48faf805a0250c525589280b9416897d3751d01d0331867c10ee971ccd849b60f34ac2cea5 SHA512 bf6a696ee48591e49ff6e1eea7d74eb4acd0457257c7733ae649059f307170f4f7bd4154ada3498a801c4e54675c802eb9df096d44063b018a2628bc654ae17f
+DIST os-brick-2.5.5.tar.gz 174931 BLAKE2B 0efa117c756728062ef0ae3bdff4ce8127bd0d800cac906960c9f2d5fcd79820e2b72753744f8acfbc52a8dce8a357583283e2adacb692cbb391c5b198b4a919 SHA512 a343cb9194ca1b497bdec55853258b8d51b109abbb3ea406aab672e87c5c68d00511928d8690bca88c37e65bb4d8bfb4cab2cd3ba6fbff2794edbdcb681e0cc0
diff --git a/dev-python/os-brick/os-brick-2.5.5.ebuild b/dev-python/os-brick/os-brick-2.5.5.ebuild
new file mode 100644
index 000000000000..0229d3350c19
--- /dev/null
+++ b/dev-python/os-brick/os-brick-2.5.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}