summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-03 00:46:37 +0100
committerSam James <sam@gentoo.org>2022-09-03 00:50:08 +0100
commitb1701a3522a4a51e4dcd57a531b608a739c620b6 (patch)
treef53447c78ed36352c1439c7036cb7154725677b6
parentsys-auth/AusweisApp2: drop 1.24.0 (diff)
downloadgentoo-b1701a35.tar.gz
gentoo-b1701a35.tar.bz2
gentoo-b1701a35.zip
sys-cluster/ucx: add 1.13.0
Bug: https://bugs.gentoo.org/861653 Closes: https://bugs.gentoo.org/798051 Closes: https://bugs.gentoo.org/822132 Closes: https://bugs.gentoo.org/832966 Closes: https://bugs.gentoo.org/868117 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/ucx/Manifest1
-rw-r--r--sys-cluster/ucx/files/ucx-1.13.0-binutils-2.39-ptr-typedef.patch25
-rw-r--r--sys-cluster/ucx/files/ucx-1.13.0-drop-werror.patch33
-rw-r--r--sys-cluster/ucx/files/ucx-1.13.0-fix-bashisms.patch44
-rw-r--r--sys-cluster/ucx/files/ucx-1.13.0-fix-fcntl-include-musl.patch103
-rw-r--r--sys-cluster/ucx/ucx-1.13.0.ebuild56
6 files changed, 262 insertions, 0 deletions
diff --git a/sys-cluster/ucx/Manifest b/sys-cluster/ucx/Manifest
index 8c266590a5e3..bc29771e377d 100644
--- a/sys-cluster/ucx/Manifest
+++ b/sys-cluster/ucx/Manifest
@@ -1,2 +1,3 @@
DIST ucx-1.10.0_rc5.tar.gz 2399950 BLAKE2B f6f78d2a3e0cd7f252354d59b9d667992c5f9f4d8ee4a41356decf4a1ed72382d8ce5213395bc6bacf1d8658f95808082cc0f825230857ddbbff19ed060efa5c SHA512 b772ad030e80bc5b0ab25d590117950d363f5f7ea1b7ed5ce0bba285d0a932205ee4d73705c094cef077c751b1cf8b6efdd4608c7df6b39d813771a0a31460ac
+DIST ucx-1.13.0.tar.gz 2770439 BLAKE2B 779bf7913ec1d0f5aebfd12d4eda90c83f6dae746e82bb818c4d981f6f564ecb37b6e003c3718db4ad74f25aa19fcbeb0ff98ed6349e254b7c707b4dda3c8974 SHA512 bea02adeb5c4286df360cfe788b40afde3e0404c659678497b53e753851e091de766f32aef39bd6f76e71802c88f0e0ed49c31af0c908ce2d9f3edc79ed6f933
DIST ucx-1.9.0.tar.gz 2467338 BLAKE2B 4d2d18c530f99a56baeb1dec88a7dba813970d3f501eb08f637dc7cefcfe5e564bc121e50c1842ea94e927a0fd657847c571241e3dd9601cdde207729d32d721 SHA512 2e8507e9cbba9ea445efdf8be5b5128dfc76cce30111805e9f7a5618bbbbb77d2bb449b6ad5e415f086b3156b63128306671d3a906583248cde720edb4241c67
diff --git a/sys-cluster/ucx/files/ucx-1.13.0-binutils-2.39-ptr-typedef.patch b/sys-cluster/ucx/files/ucx-1.13.0-binutils-2.39-ptr-typedef.patch
new file mode 100644
index 000000000000..2eb863e6bdea
--- /dev/null
+++ b/sys-cluster/ucx/files/ucx-1.13.0-binutils-2.39-ptr-typedef.patch
@@ -0,0 +1,25 @@
+https://github.com/openucx/ucx/commit/edd14921fa0a3e8cf631ef1a08fc724e44d072df
+https://bugs.gentoo.org/868117
+
+From 6b6128efd416831cec3a1820f7d1c8e648b79448 Mon Sep 17 00:00:00 2001
+From: Hui Zhou <hzhou321@anl.gov>
+Date: Sun, 14 Aug 2022 23:29:09 -0500
+Subject: [PATCH] UCS/DEBUG: replace PTR with void *
+
+The PTR macro is missing on the latest Arch linux.
+--- a/src/ucs/debug/debug.c
++++ b/src/ucs/debug/debug.c
+@@ -272,10 +272,10 @@ static int load_file(struct backtrace_file *file)
+ goto err_close;
+ }
+
+- symcount = bfd_read_minisymbols(file->abfd, 0, (PTR)&file->syms, &size);
++ symcount = bfd_read_minisymbols(file->abfd, 0, (void *)&file->syms, &size);
+ if (symcount == 0) {
+ free(file->syms);
+- symcount = bfd_read_minisymbols(file->abfd, 1, (PTR)&file->syms, &size);
++ symcount = bfd_read_minisymbols(file->abfd, 1, (void *)&file->syms, &size);
+ }
+ if (symcount < 0) {
+ goto err_close;
+
diff --git a/sys-cluster/ucx/files/ucx-1.13.0-drop-werror.patch b/sys-cluster/ucx/files/ucx-1.13.0-drop-werror.patch
new file mode 100644
index 000000000000..a0901ce23c18
--- /dev/null
+++ b/sys-cluster/ucx/files/ucx-1.13.0-drop-werror.patch
@@ -0,0 +1,33 @@
+--- a/config/m4/compiler.m4
++++ b/config/m4/compiler.m4
+@@ -10,7 +10,7 @@
+ #
+ # Initialize CFLAGS
+ #
+-BASE_CFLAGS="-g -Wall -Werror"
++BASE_CFLAGS="-g -Wall"
+
+
+ #
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -26,7 +26,7 @@ EXAMPLE_CUDA_CFLAGS = $(CFLAGS_PEDANTIC)
+ EXAMPLE_CUDA_CPPFLAGS =
+ endif
+
+-EXAMPLE_CCLD_FLAGS = -lucs -I$(includedir) -L$(libdir) -Wall -Werror -Wl,-rpath,$(libdir) \
++EXAMPLE_CCLD_FLAGS = -lucs -I$(includedir) -L$(libdir) -Wall -Wl,-rpath,$(libdir) \
+ $(EXAMPLE_CUDA_LD_FLAGS) $(EXAMPLE_CUDA_LIBS) $(EXAMPLE_CUDA_CPPFLAGS)
+
+ installcheck-local:
+--- a/test/apps/sockaddr/Makefile.am
++++ b/test/apps/sockaddr/Makefile.am
+@@ -12,7 +12,7 @@ noinst_HEADERS = \
+ sa_util.h
+
+ sa_CXXFLAGS = \
+- -std=c++11 -g -Wall -Werror
++ -std=c++11 -g -Wall
+
+ sa_CPPFLAGS = $(BASE_CPPFLAGS)
+
diff --git a/sys-cluster/ucx/files/ucx-1.13.0-fix-bashisms.patch b/sys-cluster/ucx/files/ucx-1.13.0-fix-bashisms.patch
new file mode 100644
index 000000000000..f152c152fcbb
--- /dev/null
+++ b/sys-cluster/ucx/files/ucx-1.13.0-fix-bashisms.patch
@@ -0,0 +1,44 @@
+https://github.com/openucx/ucx/pull/8494
+
+From c65087d7984f516485c11b4b732d9ac2676a494e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 3 Sep 2022 00:28:28 +0100
+Subject: [PATCH] config: Fix bashisms in configure
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Fixes configure warnings/errors like:
+```
+checking for go... yes
+./configure: 26781: test: xyes: unexpected operator
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/config/m4/go.m4
++++ b/config/m4/go.m4
+@@ -21,7 +21,7 @@ AS_IF([test "x$with_go" != xno],
+ [AS_VERSION_COMPARE([1.16], [`go version | awk '{print substr($3, 3, length($3)-2)}'`],
+ [go_happy="yes"], [go_happy="yes"], [go_happy=no])],
+ [go_happy=no])
+- AS_IF([test "x$go_happy" == xno],
++ AS_IF([test "x$go_happy" = xno],
+ [AS_IF([test "x$with_go" = "xguess"],
+ [AC_MSG_WARN([Disabling GO support - GO compiler version 1.16 or newer not found.])],
+ [AC_MSG_ERROR([GO support was explicitly requested, but go compiler not found.])])])
+--- a/configure.ac
++++ b/configure.ac
+@@ -159,7 +159,7 @@ AC_ARG_WITH([docs_only],
+ AC_DEFUN([UCX_DX_ENABLE_CHECK],
+ [AS_IF([DX_TEST_FEATURE($1)],
+ [],
+- [AS_IF([test "x$enable_doxygen_$1" == xyes],
++ [AS_IF([test "x$enable_doxygen_$1" = xyes],
+ [AC_MSG_ERROR([--enable-doxygen-$1 was specified, but $1 tools were not found])],
+ [])])])
+
diff --git a/sys-cluster/ucx/files/ucx-1.13.0-fix-fcntl-include-musl.patch b/sys-cluster/ucx/files/ucx-1.13.0-fix-fcntl-include-musl.patch
new file mode 100644
index 000000000000..2d80ffeaa3d6
--- /dev/null
+++ b/sys-cluster/ucx/files/ucx-1.13.0-fix-fcntl-include-musl.patch
@@ -0,0 +1,103 @@
+https://github.com/openucx/ucx/pull/8495
+
+From 77ea0b015bc2d18f4a6bc2ba0fb9b71ac7532199 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 3 Sep 2022 00:44:28 +0100
+Subject: [PATCH 1/2] UCM: Fix deprecated <sys/fcntl.h> includes
+
+Fix deprecation warnings like:
+```
+In file included from /var/tmp/portage/sys-cluster/ucx-1.10.0_rc5/work/ucx-1.10.0-rc5/src/ucs/sys/sys.h:29,
+ from mmap/install.c:21:
+/usr/include/sys/fcntl.h:1:2: error: #warning redirecting incorrect #include <sys/fcntl.h> to <fcntl.h> [-Werror=cpp[https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html#index-Wcpp]]
+ 1 | #warning redirecting incorrect #include <sys/fcntl.h> to <fcntl.h>
+ | ^~~~~~~
+```
+
+Bug: https://bugs.gentoo.org/832966
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/src/tools/profile/read_profile.c
++++ b/src/tools/profile/read_profile.c
+@@ -13,12 +13,12 @@
+ #include <ucs/sys/string.h>
+
+ #include <sys/signal.h>
+-#include <sys/fcntl.h>
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
+ #include <stdlib.h>
+ #include <getopt.h>
++#include <fcntl.h>
+ #include <unistd.h>
+ #include <string.h>
+ #include <assert.h>
+--- a/src/ucm/util/reloc.c
++++ b/src/ucm/util/reloc.c
+@@ -17,7 +17,6 @@
+ #include <ucs/sys/string.h>
+ #include <ucs/sys/sys.h>
+
+-#include <sys/fcntl.h>
+ #include <sys/mman.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- a/test/apps/sockaddr/sa_tcp.cc
++++ b/test/apps/sockaddr/sa_tcp.cc
+@@ -8,8 +8,8 @@
+
+ #include <sys/socket.h>
+ #include <sys/epoll.h>
+-#include <sys/fcntl.h>
+ #include <arpa/inet.h>
++#include <fcntl.h>
+ #include <unistd.h>
+ #include <cstring>
+ #include <cerrno>
+
+From 9f9e50e5472e390c86147b9031ddd8525207822a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 3 Sep 2022 00:44:56 +0100
+Subject: [PATCH 2/2] UCS: Fix deprecated <sys/fcntl.h> includes
+
+Fix deprecation warnings like:
+```
+In file included from /var/tmp/portage/sys-cluster/ucx-1.10.0_rc5/work/ucx-1.10.0-rc5/src/ucs/sys/sys.h:29,
+ from mmap/install.c:21:
+/usr/include/sys/fcntl.h:1:2: error: #warning redirecting incorrect #include <sys/fcntl.h> to <fcntl.h> [-Werror=cpp[https://gcc.gnu.org/onlinedocs/gcc/Warning-Options.html#index-Wcpp]]
+ 1 | #warning redirecting incorrect #include <sys/fcntl.h> to <fcntl.h>
+ | ^~~~~~~
+```
+
+Bug: https://bugs.gentoo.org/832966
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/src/ucs/sys/sys.h
++++ b/src/ucs/sys/sys.h
+@@ -26,7 +26,6 @@
+ #include <sys/time.h>
+ #include <sys/types.h>
+ #include <sys/uio.h>
+-#include <sys/fcntl.h>
+ #include <sys/stat.h>
+ #include <sys/syscall.h>
+ #include <sys/param.h>
+@@ -36,6 +35,7 @@
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <assert.h>
++#include <fcntl.h>
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <string.h>
+--- a/test/gtest/ucs/test_vfs.cc
++++ b/test/gtest/ucs/test_vfs.cc
+@@ -12,7 +12,7 @@ extern "C" {
+ #include <ucs/vfs/sock/vfs_sock.h>
+ }
+
+-#include <sys/fcntl.h>
++#include <fcntl.h>
+ #include <time.h>
+
+
+
diff --git a/sys-cluster/ucx/ucx-1.13.0.ebuild b/sys-cluster/ucx/ucx-1.13.0.ebuild
new file mode 100644
index 000000000000..983466a7cf98
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.13.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_PV=${PV/_/-}
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="https://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 -riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.13.0-drop-werror.patch
+ "${FILESDIR}"/${PN}-1.13.0-fix-bashisms.patch
+ "${FILESDIR}"/${PN}-1.13.0-fix-fcntl-include-musl.patch
+ "${FILESDIR}"/${P}-binutils-2.39-ptr-typedef.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" econf \
+ --disable-compiler-opt \
+ --without-fuse3 \
+ --without-go \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}