summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-20 08:08:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-20 10:34:35 +0200
commitb18453fc1865180c1ffa30833de12313cffaa837 (patch)
treed0f37ffc255e1dd99a045341e26f7724da44312c
parentdev-haskell/hdbc: drop USE=test support, requres testpack (diff)
downloadgentoo-b18453fc.tar.gz
gentoo-b18453fc.tar.bz2
gentoo-b18453fc.zip
dev-python/botocore: Bump to 1.17.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.17.46.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c45782e7cd60..6ab4f36662c6 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -7,3 +7,4 @@ DIST botocore-1.17.31.tar.gz 6665851 BLAKE2B dbc89d1216f9fda89c6185baccfdf2878c2
DIST botocore-1.17.34.tar.gz 6683317 BLAKE2B a3229c09f7c21a95140e22d9902161b705bccf1a9559b6ba2bf45e5e79f2f2af7e86fcbae3654405faf73e4eb6a8f86a88c407aafb411c646d54aed72af8b162 SHA512 f5fe7803c4e083de7515f7bd58f84709ebaa8007d707273c6bf9fac1391b7d5ab7e8771725db59b9b6b5dd60e71f34140ae5435dec18ffc364c1779172de9bab
DIST botocore-1.17.40.tar.gz 6693291 BLAKE2B 233042aa9641d874b0d3d5907d8d4afabbd3ea72756f2ba8ca219b3f5f1c246465cba6809e23a670db2a9d75e2c8f1e04c3c12cafb73952530fbf847ad7b42d6 SHA512 b9d0e180d5e8e659d13676110856dc01943c4057c23437a41edf40366e76f2c92eb119c004fde45ee53e2b82b1716e0334a18a6b5ea4e4de30f02cfd5b711b0a
DIST botocore-1.17.43.tar.gz 6706807 BLAKE2B 6440bce1fc78ee7339e0c24b60ecb166b3cbf7c9f790f4ec208ea6b42b396710c245512b1e4d05bdb17cee5a8d47770bc43ca22a9675e3dbdc58fcba1c4111c9 SHA512 387c96113363a01b670b3797411dd28a01a98bb8139f404da272431df733231c6aeabda018001f868a2a4c6801f86d35f0f9b4353446d5c98333b44099f858aa
+DIST botocore-1.17.46.tar.gz 6738493 BLAKE2B 2e5ee1241af91c19cef0ac575c5ad68d46277e8b2f0f1f719428f7b4026303a47e48b8a8240c1121cfe35c6310be5fde3f0cfa2aa3f3321249811eb510b47f94 SHA512 a11de252454477d478f2b5d0b5978b24961baa3942936ef5990c421709d0b8081e8dbf020b76cce5c3c43d3fe0467cedf5441918767163712e0ad178c9cba80d
diff --git a/dev-python/botocore/botocore-1.17.46.ebuild b/dev-python/botocore/botocore-1.17.46.ebuild
new file mode 100644
index 000000000000..8737f742498b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.17.46.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # py3.9
+ find -name '*.py' -exec \
+ sed -i -e 's:cElementTree:ElementTree:' {} + || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}