summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-24 20:02:09 +0000
committerSam James <sam@gentoo.org>2021-11-24 20:02:09 +0000
commitb1e3436ee676da49d068da88d21e5cfc549f282e (patch)
treedd79956e94d816ea370896b896e9d9e2ac52e323
parentx11-drivers/nvidia-drivers: drop 470.62.12:0/vulkan (diff)
downloadgentoo-b1e3436ee676da49d068da88d21e5cfc549f282e.tar.gz
gentoo-b1e3436ee676da49d068da88d21e5cfc549f282e.tar.bz2
gentoo-b1e3436ee676da49d068da88d21e5cfc549f282e.zip
dev-tex/html2latex: use src_configure, use RDEPEND
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-tex/html2latex/html2latex-1.1-r3.ebuild (renamed from dev-tex/html2latex/html2latex-1.1-r2.ebuild)13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-tex/html2latex/html2latex-1.1-r2.ebuild b/dev-tex/html2latex/html2latex-1.1-r3.ebuild
index 1321a9313436..dd5a18cfc929 100644
--- a/dev-tex/html2latex/html2latex-1.1-r2.ebuild
+++ b/dev-tex/html2latex/html2latex-1.1-r3.ebuild
@@ -19,11 +19,17 @@ DEPEND="dev-perl/HTML-Tree
dev-perl/XML-Simple
imagemagick? ( media-gfx/imagemagick )
libwww? ( dev-perl/libwww-perl )"
+RDEPEND="${DEPEND}"
-src_compile() {
+src_configure() {
# HTML::LaTex
- cd HTML
+ cd HTML || die
perl-module_src_configure
+}
+
+src_compile() {
+ # HTML::LaTex
+ cd HTML || die
perl-module_src_compile
}
@@ -33,8 +39,9 @@ src_install() {
dodoc README TODO
# HTML::LaTex
- cd HTML
+ cd HTML || die
perl-module_src_install
+
# rm unwanted README.win
rm "${ED}"/usr/share/doc/${PF}/README.win.txt || die
}