summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-31 10:00:10 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-31 10:00:57 +0100
commitb1f45aa5ab0a8ebe2c14e407b66188b51a7e0eae (patch)
tree5e06f0e628fe7178ea3d86bd484fb8dcf1f22cef
parentdev-vcs/hub: Version Bump (diff)
downloadgentoo-b1f45aa5ab0a8ebe2c14e407b66188b51a7e0eae.tar.gz
gentoo-b1f45aa5ab0a8ebe2c14e407b66188b51a7e0eae.tar.bz2
gentoo-b1f45aa5ab0a8ebe2c14e407b66188b51a7e0eae.zip
app-text/multitail: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--app-text/multitail/Manifest1
-rw-r--r--app-text/multitail/multitail-6.4.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-text/multitail/Manifest b/app-text/multitail/Manifest
index 72dc712e9acb..3a134546932f 100644
--- a/app-text/multitail/Manifest
+++ b/app-text/multitail/Manifest
@@ -1 +1,2 @@
DIST multitail-6.4.1.tgz 155717 SHA256 8a6baecf3537c791f70645f3613bfea0c91a22040f2531bfe03b6d0cdd112134 SHA512 14d4785df257aaac8b3c1a5de8aa48a0b6c3e7829867e1fbc8d458636ecafcf506e09b12581cf562e1f503218b1729e47e9197f541bede90dc0a4d5e916b1c8b WHIRLPOOL 467d9fd6d089aebe597475d07217baadcb280ea952ae731310365a55046009c808b16657485c037f54dd746e2103f318c3555de04d4e14f2ab2ef19bbc408543
+DIST multitail-6.4.2.tgz 155757 SHA256 af1d5458a78ad3b747c5eeb135b19bdca281ce414cefdc6ea0cff6d913caa1fd SHA512 668c453372ba1e4013aa5191c697bdcaad82c84732841c120a506bee063d2134941e93aed63f96e5aeeb6045829a13aba012f9514dbd9520ab4f1b9b75b42dbd WHIRLPOOL c74a85671f2772a6b5d8cc224481fc1793d851573e77e9b7cc4bc3e0569b4ba58ca63989f7f82e2e91dabc29363b87dd361305178b8c174fe2a7b250c86e731b
diff --git a/app-text/multitail/multitail-6.4.2.ebuild b/app-text/multitail/multitail-6.4.2.ebuild
new file mode 100644
index 000000000000..372f054c5a1d
--- /dev/null
+++ b/app-text/multitail/multitail-6.4.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug examples unicode"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT="test" # bug #492270
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-6.4.1-gentoo.patch
+
+ sed \
+ -e "/^DESTDIR/s:=.*$:=${EROOT}:g" \
+ -i Makefile || die
+
+ sed \
+ -e "s:/usr/bin/xclip:${EPREFIX}/usr/bin/xclip:g" \
+ -i xclip.c ${PN}.conf || die
+
+ tc-export CC PKG_CONFIG
+
+ use debug && append-flags "-D_DEBUG"
+}
+
+src_compile() {
+ emake UTF8_SUPPORT=$(usex unicode)
+}
+
+src_install () {
+ dobin multitail
+
+ insinto /etc
+ doins multitail.conf
+
+ DOCS=( readme.txt thanks.txt )
+ HTML_DOCS=( manual.html )
+ einstalldocs
+
+ doman multitail.1
+
+ if use examples; then
+ docinto examples
+ dodoc conversion-scripts/colors-example.{pl,sh} conversion-scripts/convert-{geoip,simple}.pl
+ fi
+}
+
+pkg_postinst() {
+ optfeature "send a buffer to the X clipboard" x11-misc/xclip
+}