summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-09-17 02:51:14 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-09-17 18:48:37 +0200
commitb1fda0fbff61ccdaa87d395b6798ce05f2ef54a8 (patch)
tree5e20422e59c8445fb4832feacf57245268b5d0ff
parentsys-kernel/gentoo-sources: Linux patch 4.19.146 (diff)
downloadgentoo-b1fda0fb.tar.gz
gentoo-b1fda0fb.tar.bz2
gentoo-b1fda0fb.zip
dev-python/pooch: new package
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17570 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--dev-python/pooch/Manifest1
-rw-r--r--dev-python/pooch/metadata.xml16
-rw-r--r--dev-python/pooch/pooch-1.2.0.ebuild25
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
new file mode 100644
index 000000000000..1ed64bb0458e
--- /dev/null
+++ b/dev-python/pooch/Manifest
@@ -0,0 +1 @@
+DIST pooch-1.2.0.tar.gz 212831 BLAKE2B 73db6d6ef432960704103cee92c72d80243c9f73c3896458b20a734fc577f4982c0ecd0c72d512f8d355f28f48ca084755816196431aa7f27eab9c467e4e0654 SHA512 dfb7d890d3211f8f737dc79fa81cc895c166dc96b05d86ad2df9b33f1da950a05bce8e6a80abdb467edef2157bd13a8209771ced91a17023903c5541a1b998d3
diff --git a/dev-python/pooch/metadata.xml b/dev-python/pooch/metadata.xml
new file mode 100644
index 000000000000..1911018bccef
--- /dev/null
+++ b/dev-python/pooch/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Pooch manages your Python library's sample data files: it automatically downloads and stores them in a local directory,
+ with support for versioning and corruption checks.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">fatiando/pooch</remote-id>
+ <remote-id type="pypi">pooch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pooch/pooch-1.2.0.ebuild b/dev-python/pooch/pooch-1.2.0.ebuild
new file mode 100644
index 000000000000..42f0780637f9
--- /dev/null
+++ b/dev-python/pooch/pooch-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..8})
+
+inherit distutils-r1
+
+DESCRIPTION="manages your Python library's sample data files"
+HOMEPAGE="https://github.com/fatiando/pooch"
+SRC_URI="https://github.com/fatiando/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme