summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:38:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 11:02:16 +0100
commitb1fe7da30e2eb88de6df6b0d100e4ea3b904fc90 (patch)
treef59369d956484c286141cd9d72e12431c587ad70
parentdev-python/terminaltables: Switch to PEP 517 build (diff)
downloadgentoo-b1fe7da3.tar.gz
gentoo-b1fe7da3.tar.bz2
gentoo-b1fe7da3.zip
dev-python/testpath: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/testpath/testpath-0.5.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/testpath/testpath-0.5.0-r1.ebuild b/dev-python/testpath/testpath-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..1bd8ec23135b
--- /dev/null
+++ b/dev-python/testpath/testpath-0.5.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc