summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-30 15:53:34 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-30 20:58:38 +0100
commitb20fb0275a32e51daf4a31707f9fe65b35964e11 (patch)
tree95f01630d4cc0bae9e94d7e8e64afc7725f26b34
parentdev-python/ytmusicapi: bump to 1.5.1 (diff)
downloadgentoo-b20fb0275a32e51daf4a31707f9fe65b35964e11.tar.gz
gentoo-b20fb0275a32e51daf4a31707f9fe65b35964e11.tar.bz2
gentoo-b20fb0275a32e51daf4a31707f9fe65b35964e11.zip
dev-dotnet/fable: remove bad test for USE=debug
Closes: https://bugs.gentoo.org/922684 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-dotnet/fable/fable-4.9.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-dotnet/fable/fable-4.9.0.ebuild b/dev-dotnet/fable/fable-4.9.0.ebuild
index a36d9e9e9072..e564ab360793 100644
--- a/dev-dotnet/fable/fable-4.9.0.ebuild
+++ b/dev-dotnet/fable/fable-4.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -318,6 +318,13 @@ src_unpack() {
src_prepare() {
rm Fable.Standalone.sln || die
+ if use debug ; then
+ DOTNET_PKG_REMOVE_PROJECTS+=(
+ # Seems to hang but in reality it fails with USE=debug, bug #922684
+ tests/Python/Fable.Tests.Python.fsproj
+ )
+ fi
+
dotnet-pkg_src_prepare
edotnet sln ./Fable.sln remove "${DOTNET_PKG_REMOVE_PROJECTS[@]}"
}