summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-26 21:53:56 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-26 21:53:56 -0700
commitb21286d0b48a4a18e1cc39b375976c9330e90ca9 (patch)
tree7e05999e1a4b5e71ba6e4418c07e0eca50b72996
parentgnome-extra/yelp: Version bump to 42.1 (diff)
downloadgentoo-b21286d0b48a4a18e1cc39b375976c9330e90ca9.tar.gz
gentoo-b21286d0b48a4a18e1cc39b375976c9330e90ca9.tar.bz2
gentoo-b21286d0b48a4a18e1cc39b375976c9330e90ca9.zip
gnome-extra/libgsf: Version bump to 1.14.49
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.49.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index baadf67f045a..49b2a2751113 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.48.tar.xz 701760 BLAKE2B 762fe424ad45ac9739e1ea2cd9971f80f9c4d573147c6043c6bbf7b416a6c69c3b0bbfa42f6424176a545f7f9e7257d33e62c92482945786bb142063390a9d08 SHA512 6efba54c1427f9bdf71203b265ee4cdaa7366f78f299d38deffb657198244fb6436ab4e077a010079a28832539cdef08796e43feb76450ab0420da56016cd95e
+DIST libgsf-1.14.49.tar.xz 702644 BLAKE2B 05ee17200d5170380138a7996dd37d5473eb9fe9a13cfb06b68e17470525d9640a4921d111e83963f245ecf6b669116322d9358d9a0b473c8149c56ff9c983ba SHA512 a847a3c7fe26865e110bb87cb7ed74c477fdaf41fdec1c97cd3ea85ab3ba2f618e609a38fb4087a2c9b58d8d4b430c2148c93cbbb8425af41b6c751efef3298e
diff --git a/gnome-extra/libgsf/libgsf-1.14.49.ebuild b/gnome-extra/libgsf/libgsf-1.14.49.ebuild
new file mode 100644
index 000000000000..795fb272712c
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.49.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgsf"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ test? ( dev-perl/XML-Parser )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}