summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-02 09:20:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-02 09:21:27 +0200
commitb21df8152057a2405a47fcbd23c68723839bb033 (patch)
tree612383f4cf9b6d5c5ddb13fbc6970fd573396b25
parentnet-misc/icaclient: Removed old (diff)
downloadgentoo-b21df815.tar.gz
gentoo-b21df815.tar.bz2
gentoo-b21df815.zip
x11-misc/xnee: Disable libgnomeui dependency
Thanks to Debian for the patch. Closes: https://bugs.gentoo.org/644342 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--x11-misc/xnee/files/xnee-3.19-libgnomeui-only-for-applets.patch117
-rw-r--r--x11-misc/xnee/xnee-3.19-r2.ebuild77
2 files changed, 194 insertions, 0 deletions
diff --git a/x11-misc/xnee/files/xnee-3.19-libgnomeui-only-for-applets.patch b/x11-misc/xnee/files/xnee-3.19-libgnomeui-only-for-applets.patch
new file mode 100644
index 000000000000..4e80dacd20b0
--- /dev/null
+++ b/x11-misc/xnee/files/xnee-3.19-libgnomeui-only-for-applets.patch
@@ -0,0 +1,117 @@
+--- a/configure.in 2014/05/06 14:13:59 1.134
++++ b/configure.in 2018/01/01 23:06:56 1.135
+@@ -382,62 +382,63 @@
+ fi
+
+
+- GNOMEUI2_MODULE="libgnomeui-2.0"
+- GNOMEUI2_VERSION="2.0.0"
+-
+-
+- if `$PKGCFG --exists $GNOMEUI2_MODULE >= $GNOMEUI2_VERSION`
+- then
+- GTK_MODULES="$GTK_MODULES $GNOMEUI2_MODULE"
+- GTK_ERR=1
+- fi
+-
+- libgnomeui_CFLAGS=`$PKGCFG --cflags $GNOMEUI2_MODULE `
+- libgnomeui_LIBS=`$PKGCFG --libs $GNOMEUI2_MODULE `
+-
+-
+- AC_SUBST(libgnomeui_CFLAGS)
+- AC_SUBST(libgnomeui_LIBS)
+-
+ PIXMAP_DIR=pixmap
+
+-
+- if test x$buildgapplet = xtrue ;
++ if test x$buildgapplet = xtrue;
+ then
+-
+- if test x$GTKCONF = x ;
+- then
+- echo " **************************************** "
+- echo " * WARNING, missing program: gtk-config *"
+- echo " **************************************** "
+- echo ""
+- echo " On Debian based distros, install sth like: libgtk2.0-dev"
+- echo ""
+- echo "However, I will try my best to continue without gtk-config. "
+- echo "Will not be able to check for gtk/gnome header files properly"
+- echo "On most platforms this implies no problem"
+- echo ""
+- else
+- GTK_PREFIX=`$GTKCONF --prefix`
+- GTK_INC_PATH=$GTK_PREFIX/include/$GNOMEUI2_MODULE/
+- GNOME_H_FILE=$GTK_INC_PATH/gnome.h
+-
+- ls -l $GNOME_H_FILE 2>/dev/null >/dev/null
+-
+- MISSING_GNOME_H=$?
+
+- if test x$MISSING_GNOME_H != x0 ;
++ GNOMEUI2_MODULE="libgnomeui-2.0"
++ GNOMEUI2_VERSION="2.0.0"
++
++
++ if `$PKGCFG --exists $GNOMEUI2_MODULE >= $GNOMEUI2_VERSION`
++ then
++ GTK_MODULES="$GTK_MODULES $GNOMEUI2_MODULE"
++ GTK_ERR=1
++ fi
++
++ libgnomeui_CFLAGS=`$PKGCFG --cflags $GNOMEUI2_MODULE `
++ libgnomeui_LIBS=`$PKGCFG --libs $GNOMEUI2_MODULE `
++
++
++ AC_SUBST(libgnomeui_CFLAGS)
++ AC_SUBST(libgnomeui_LIBS)
++
++
++
++ if test x$GTKCONF = x ;
+ then
+- echo "Missing GNOME header file (gnome.h), you need to install development packages"
+- echo "On a Debian based distro system do:"
+- echo ""
+- echo " sudo apt-get install libgnome2-dev"
+- echo ""
+-echo exit 1
+- fi
+- fi
+-
+- fi
++ echo " **************************************** "
++ echo " * WARNING, missing program: gtk-config *"
++ echo " **************************************** "
++ echo ""
++ echo " On Debian based distros, install sth like: libgtk2.0-dev"
++ echo ""
++ echo "However, I will try my best to continue without gtk-config. "
++ echo "Will not be able to check for gtk/gnome header files properly"
++ echo "On most platforms this implies no problem"
++ echo ""
++ else
++ GTK_PREFIX=`$GTKCONF --prefix`
++ GTK_INC_PATH=$GTK_PREFIX/include/$GNOMEUI2_MODULE/
++ GNOME_H_FILE=$GTK_INC_PATH/gnome.h
++
++ ls -l $GNOME_H_FILE 2>/dev/null >/dev/null
++
++ MISSING_GNOME_H=$?
++
++ if test x$MISSING_GNOME_H != x0 ;
++ then
++ echo "Missing GNOME header file (gnome.h), you need to install development packages"
++ echo "On a Debian based distro system do:"
++ echo ""
++ echo " sudo apt-get install libgnome2-dev"
++ echo ""
++ echo exit 1
++ fi
++ fi
++
++ fi
+ fi
+
+
diff --git a/x11-misc/xnee/xnee-3.19-r2.ebuild b/x11-misc/xnee/xnee-3.19-r2.ebuild
new file mode 100644
index 000000000000..0a3540a531d3
--- /dev/null
+++ b/x11-misc/xnee/xnee-3.19-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic
+
+DESCRIPTION="Program suite to record, replay and distribute user actions"
+HOMEPAGE="https://xnee.wordpress.com/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome xosd"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXtst
+ x11-libs/libxcb
+ gnome? (
+ >=gnome-base/gconf-2
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig
+ sys-devel/gettext
+ gnome? ( virtual/imagemagick-tools[jpeg,png] )
+"
+
+# This needs RECORD extension from X.org server which isn't necessarily
+# enabled. Xlib: extension "RECORD" missing on display ":0.0".
+RESTRICT="test"
+
+DOCS=( AUTHORS BUGS ChangeLog FAQ NEWS README TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.18-linker.patch
+ "${FILESDIR}"/${P}-libgnomeui-only-for-applets.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+ econf \
+ $(use_enable gnome gui) \
+ $(use_enable xosd buffer_verbose) \
+ $(use_enable xosd verbose) \
+ $(use_enable xosd) \
+ --disable-gnome-applet \
+ --disable-static \
+ --disable-static-programs \
+ --enable-cli \
+ --enable-lib
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ default
+ use gnome && make_desktop_entry gnee Gnee ${PN} "Utility;GTK"
+ find "${ED}" -name '*.la' -delete || die
+}