summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 13:56:15 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 13:56:18 +0100
commitb231eca789fe217f37537e185f023c8d47dba62a (patch)
tree8bbf82def66ddf45b9b3f71983255cf68e65ccb7
parentdev-perl/Wx-Scintilla: Works with wxGTK 3.2 (diff)
downloadgentoo-b231eca7.tar.gz
gentoo-b231eca7.tar.bz2
gentoo-b231eca7.zip
games-board/openyahtzee: Port to wxGTK 3.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--games-board/openyahtzee/files/openyahtzee-1.9.3-wx32.patch11
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild29
2 files changed, 40 insertions, 0 deletions
diff --git a/games-board/openyahtzee/files/openyahtzee-1.9.3-wx32.patch b/games-board/openyahtzee/files/openyahtzee-1.9.3-wx32.patch
new file mode 100644
index 000000000000..0ac1d300bd0b
--- /dev/null
+++ b/games-board/openyahtzee/files/openyahtzee-1.9.3-wx32.patch
@@ -0,0 +1,11 @@
+--- a/src/about.cpp
++++ b/src/about.cpp
+@@ -40,7 +40,7 @@ void AboutDialog::addControlsAndLayout()
+
+ wxStaticText* app_label = new wxStaticText(this,wxID_ANY,wxT("Open Yahtzee ") wxT(VERSION));
+ app_label->SetFont(wxFont(14, wxDEFAULT, wxNORMAL, wxBOLD, false));
+- title_sizer->Add(app_label, 0, wxALL|wxALIGN_CENTER_VERTICAL|wxADJUST_MINSIZE, 10);
++ title_sizer->Add(app_label, 0, wxALL|wxALIGN_CENTER_VERTICAL, 10);
+
+ wxNotebook* notebook_main = new wxNotebook(this, wxID_ANY);
+ notebookAboutTab(notebook_main);
diff --git a/games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild b/games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild
new file mode 100644
index 000000000000..bdbe466b02da
--- /dev/null
+++ b/games-board/openyahtzee/openyahtzee-1.9.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit flag-o-matic toolchain-funcs wxwidgets
+
+DESCRIPTION="Full-featured wxWidgets version of the classic dice game Yahtzee"
+HOMEPAGE="https://openyahtzee.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openyahtzee/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+
+PATCHES=( "${FILESDIR}"/${P}-wx32.patch )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ setup-wxwidgets
+ econf --datadir=/usr/share
+}