summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:14:34 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:14:34 -0400
commitb2342287cb89c1bdb887ce0d028cb07e1eef09ac (patch)
tree38fce025d5f2b93c4a22fb05740832e482a4906d
parentdev-libs/ace: add libressl support (diff)
downloadgentoo-b2342287.tar.gz
gentoo-b2342287.tar.bz2
gentoo-b2342287.zip
dev-libs/libmowgli: add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/libmowgli/libmowgli-2.0.0-r1.ebuild26
-rw-r--r--dev-libs/libmowgli/libmowgli-9999.ebuild11
2 files changed, 33 insertions, 4 deletions
diff --git a/dev-libs/libmowgli/libmowgli-2.0.0-r1.ebuild b/dev-libs/libmowgli/libmowgli-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..510eae732ebe
--- /dev/null
+++ b/dev-libs/libmowgli/libmowgli-2.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
+HOMEPAGE="http://www.atheme.org/project/mowgli"
+SRC_URI="http://atheme.org/downloads/${P}.tar.gz"
+IUSE="libressl ssl"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+RDEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+)"
+DEPEND="${RDEPEND}"
+DOCS="AUTHORS README doc/BOOST doc/design-concepts.txt"
+
+src_configure() {
+ # disabling SSL is "broken" in 2.0.0 so we have to use this hack till 2.0.1
+ use !ssl && myconf="--with-openssl=/dev/null"
+ econf ${myconf}
+}
diff --git a/dev-libs/libmowgli/libmowgli-9999.ebuild b/dev-libs/libmowgli/libmowgli-9999.ebuild
index f2e1e27c88af..26381780b55b 100644
--- a/dev-libs/libmowgli/libmowgli-9999.ebuild
+++ b/dev-libs/libmowgli/libmowgli-9999.ebuild
@@ -1,20 +1,23 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit git-2
DESCRIPTION="Useful set of performance and usability-oriented extensions to C"
HOMEPAGE="http://www.atheme.org/project/mowgli"
EGIT_REPO_URI="git://github.com/atheme/libmowgli-2.git"
-IUSE="ssl"
+IUSE="libressl ssl"
LICENSE="BSD-2"
SLOT="2"
KEYWORDS=""
-RDEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+)"
DEPEND="${RDEPEND}"
DOCS="AUTHORS README doc/BOOST doc/design-concepts.txt"