summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-02-25 21:12:01 +0100
committerPacho Ramos <pacho@gentoo.org>2022-02-25 21:12:01 +0100
commitb24d163deef7e8948ef1b397c2b78af6c38e17eb (patch)
treef30329ee11bccc1c70d63f5980e0651d00c4beb1
parentdev-lang/ocaml: fix TEXTREL on 4.12.1 (diff)
downloadgentoo-b24d163d.tar.gz
gentoo-b24d163d.tar.bz2
gentoo-b24d163d.zip
gnome-extra/gnome-shell-extension-alphabetical-grid: Bump to 19.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-19.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
index e0770c338afa..bf761d464482 100644
--- a/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-alphabetical-grid-18.0.tar.gz 289276 BLAKE2B 8556fab62659a188c58cc98a642b81a11681ac463590b4beef537f7963b968de371af323f63ca8e989d439837443411db946561e2ab4f993c38d179890575e87 SHA512 7a68e0bbda7c1a071805f0481185941552896ee477920b4e328cf5cafea4d93b4faf474ae6bc9cde4e0d78f4e83af697fe5f9ed1a675d6de5834a97a40b5c5b6
+DIST gnome-shell-extension-alphabetical-grid-19.0.tar.gz 288661 BLAKE2B b3df5594422f7d5ba249ec5a3eebf178e845fc2f36f838f61c86c0aa1918f9ca7e942a6af358e3f1744ce7f25a507f3e97bac71848cf6c0bac6339139ffd0d3d SHA512 139f1d06ebeef3b76ac84f71190cf77ebc77571ff3b489bb86f578cfa01ce7de47e53798fece93cb6c45bd82cb6b2a425ba255c1485d5b8739da28bd9959fce8
diff --git a/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-19.0.ebuild b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-19.0.ebuild
new file mode 100644
index 000000000000..2164b03efc89
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-alphabetical-grid/gnome-shell-extension-alphabetical-grid-19.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+# Useful specially to prevent
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/4684
+# https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3180
+DESCRIPTION="Restore the alphabetical ordering of the app grid"
+HOMEPAGE="https://github.com/stuarthayhurst/alphabetical-grid-extension"
+SRC_URI="https://github.com/stuarthayhurst/alphabetical-grid-extension/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/alphabetical-grid-extension-${PV}"
+extension_uuid="AlphabeticalAppGrid@stuarthayhurst"
+
+# Tests are only useful for upstream
+RESTRICT="test"
+
+# Not useful for us
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md LICENSE.txt Makefile schemas || die
+ mv -v ui/* . || die # Searches for these files in parent dir
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}