summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-06 22:32:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-06 22:32:38 +0200
commitb2562f49cafd907403571586b911a38a15495de5 (patch)
tree3c80db98d3d62e9ed24cbc9ae47acc5c4df1baee
parentdev-python/readme_renderer: Remove old (diff)
downloadgentoo-b2562f49.tar.gz
gentoo-b2562f49.tar.bz2
gentoo-b2562f49.zip
dev-python/rq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.10.1-r2.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index bfa2f9d0f1d4..f55c1e98a83b 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1 @@
-DIST rq-1.10.1.tar.gz 599678 BLAKE2B 0673ca0eea69c3f86e50f5609a9c4ed2c2d93d331479510365a744461a5d878e6de6a9683356562754a25760f8ba1d8a65f6d5acfe878e488a70c54dc0bb5b54 SHA512 1a12bd5db27eb3f9303b2f3465c2f22092f7eebfabfc1e6aa7f65de7ea139df3833f9bbdc7061de564b2418608641b3755993bb918efbf93b04df67ca942ea09
DIST rq-1.11.gh.tar.gz 603425 BLAKE2B f6295e1d7ddbe229001076b8ca04f0f8c323eed988a7963449c2240cbc6168d48539297c16e1ce95f7ec2b8824e6f65fc1e026e76a6093e73c06dd1b847d1c5b SHA512 6e208f4c1c8c55f5847843d7933f17d2fae58e2b24cf1461fddba08894a860f8bcb55aac5c6840f2d9223b88538070c414e2e540e9bc846cef05a26b0ef38ffb
diff --git a/dev-python/rq/rq-1.10.1-r2.ebuild b/dev-python/rq/rq-1.10.1-r2.ebuild
deleted file mode 100644
index 4eb54ea3094c..000000000000
--- a/dev-python/rq/rq-1.10.1-r2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="
- https://python-rq.org/
- https://github.com/rq/rq/
-"
-SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/sentry-sdk[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}