summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-24 10:22:18 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-24 10:22:18 +0100
commitb260bb54792b1c9206bff53822e5347a7c65e04f (patch)
treeef9115cb66c3dfd385257d6a83c1acc44c39e9ba
parentdev-python/python-evdev: Bump to 1.5.0 (diff)
downloadgentoo-b260bb54.tar.gz
gentoo-b260bb54.tar.bz2
gentoo-b260bb54.zip
dev-python/tqdm: Bump to 4.63.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.63.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index c206b3dfffe5..ab52b3363922 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,2 +1,3 @@
DIST tqdm-4.62.3.tar.gz 167952 BLAKE2B d5732fc97256e1fc4f55bd1a0f69f98a87e7132cc1d8484baa12b7615da5a95ce20268515539c595c2b2aaf20f9a9434c17d581b3b90ea3cad3515150e469471 SHA512 1083ca2080163c98bbb55e124ce9d47c790e47c83cd8dad60e4c93773d1d97a50aacb5a25ddb8a2ae3691738e4f4942c88d55dab406c3e810cac18b8929d20ee
DIST tqdm-4.63.0.tar.gz 168556 BLAKE2B f4fa47290f580f0923fa4325e88b103c4175344c928844149bf4b4445816bb7e87bd176d666b93a94a5981b246541017f0a34d710becf082110caca68b9ee45d SHA512 939ac7e310204094cb0c6a935ba6a91af45cd63fa8fa83865b75d1bcea440d5ff21a4d3405f5bcce864b43159921d3ef7b92d9c390fe30902f24e4e724c7eaf9
+DIST tqdm-4.63.1.tar.gz 168619 BLAKE2B c5d282f07bd1042097ba24cfc7c5311ce53fa5b66e4f9d4b8504c5d102a4c380dfbc8bb59deee469c90d9726b7d36a34cf9c88ed07b412378f51819f789e8e9c SHA512 3d7dfb81ca6b8b72f26d6b3ef4309af19e1679d3ee805e3c1326e804df4204acc20de8d935394eac736a1598d9c5485165f3cbd2b83b746c2bbf202d3b1e4c5c
diff --git a/dev-python/tqdm/tqdm-4.63.1.ebuild b/dev-python/tqdm/tqdm-4.63.1.ebuild
new file mode 100644
index 000000000000..e8dbfbed9a0d
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.63.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}