summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-02-05 19:57:44 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-02-05 19:57:44 -0800
commitb277d708a2eceaad609bdb7f9f6656fc58c54282 (patch)
treef5b995e0211f71e26c99baedb482ac5689d21e80
parentapp-office/gnumeric/gnumeric: Version bump to 1.12.55 Closes: https://bugs.ge... (diff)
downloadgentoo-b277d708.tar.gz
gentoo-b277d708.tar.bz2
gentoo-b277d708.zip
app-text/lowdown: add 1.0.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-text/lowdown/Manifest1
-rw-r--r--app-text/lowdown/lowdown-1.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/lowdown/Manifest b/app-text/lowdown/Manifest
index 97723936e704..ca40dae54aa5 100644
--- a/app-text/lowdown/Manifest
+++ b/app-text/lowdown/Manifest
@@ -1,2 +1,3 @@
DIST lowdown-0.11.1.tar.gz 571320 BLAKE2B 28fe8cb4f164618be602770c602f3ce51c0f0e765fb9869b82cb29c50bdbe0fd92c09c10074d8968108eca59096d7e176531eb56cb2b40f1d9c00a3f944e3b8c SHA512 5a8ca9d731171b97daed7a9095bc4206d2bed9095fa267eb9270782770247743f1a096c5235fd301320418c37a478fbc71552ade105eba0e756ff687835d4efb
DIST lowdown-0.11.2.tar.gz 576599 BLAKE2B 579a5257a0c37882c1b5269d8196a974b3ac73be146ba424a129c9421091c462769f065350ede1b8437371141c17c24fa5ac4bdc65f393a92835d6e981c5b181 SHA512 f49ba1358a6de9ab792cf1fb7586e0e326b8ba9a153c234079825534cbdc2d10b6af32d5612b11490b97dbd6c0bea10a79752bf1ad7e7d8af871aa20332fed9e
+DIST lowdown-1.0.0.tar.gz 576167 BLAKE2B fec9857ef1110f4767ff6244dcf06fa9c69a56d4b8709217cf05a148757512e2cb8c141b112673f0cffa260d7e2c376b9905bb16092e3f97f97007dcef922bcb SHA512 fe18db1f3d6dbc4fe0ae33ebcdeb1646b20d6fedd265e29d53475f7931b5b60329a653f9af864a39ff4caa0131751fcbffff0d94cb9519401a3479ada29bd7b8
diff --git a/app-text/lowdown/lowdown-1.0.0.ebuild b/app-text/lowdown/lowdown-1.0.0.ebuild
new file mode 100644
index 000000000000..bf31fdccbcaf
--- /dev/null
+++ b/app-text/lowdown/lowdown-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.10.0-pkgconfig-libmd.patch"
+ "${FILESDIR}/lowdown-0.11.1-linking.patch"
+)
+
+src_configure() {
+ append-flags -fPIC
+ tc-export CC AR
+
+ ./configure \
+ PREFIX="/usr" \
+ MANDIR="/usr/share/man" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LIBDIR="/usr/$(get_libdir)" \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
+src_test() {
+ emake regress
+}