summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 11:32:06 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 11:58:29 +0100
commitb2c63b3a61cc0bcb93a062604eaedd3191ed736f (patch)
treed4c6204b8010fc763a1aab7673ee71ad53d35e29
parentsys-fs/fuse: add 3.14.0 (diff)
downloadgentoo-b2c63b3a61cc0bcb93a062604eaedd3191ed736f.tar.gz
gentoo-b2c63b3a61cc0bcb93a062604eaedd3191ed736f.tar.bz2
gentoo-b2c63b3a61cc0bcb93a062604eaedd3191ed736f.zip
dev-python/python-xmlsec: Deselect a failing test
Closes: https://bugs.gentoo.org/888221 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-xmlsec/Manifest2
-rw-r--r--dev-python/python-xmlsec/python-xmlsec-1.3.12-r1.ebuild16
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/python-xmlsec/Manifest b/dev-python/python-xmlsec/Manifest
index 741cd6ebaccf..8bd1049057d4 100644
--- a/dev-python/python-xmlsec/Manifest
+++ b/dev-python/python-xmlsec/Manifest
@@ -1 +1 @@
-DIST python-xmlsec-1.3.12.tar.gz 77722 BLAKE2B b5ecece8063b823cdbe4d58967d10026bdc6f3774954021a3739d579ba3c5a08130af1792921c7892e6bc3d00f88ac83ab30e862775e419e0dad40b990b10cbe SHA512 19c5e3bf58b4b0f8a1cca3e60c08348b02ae298620f8c02b8cfb325aecf0313cb2bd1af89507b754ebe4c35af3b031e232d15ddcd42deae0821c9c0d7571aa7c
+DIST python-xmlsec-1.3.12.gh.tar.gz 77722 BLAKE2B b5ecece8063b823cdbe4d58967d10026bdc6f3774954021a3739d579ba3c5a08130af1792921c7892e6bc3d00f88ac83ab30e862775e419e0dad40b990b10cbe SHA512 19c5e3bf58b4b0f8a1cca3e60c08348b02ae298620f8c02b8cfb325aecf0313cb2bd1af89507b754ebe4c35af3b031e232d15ddcd42deae0821c9c0d7571aa7c
diff --git a/dev-python/python-xmlsec/python-xmlsec-1.3.12-r1.ebuild b/dev-python/python-xmlsec/python-xmlsec-1.3.12-r1.ebuild
index eba0c418d064..439a5b0cea28 100644
--- a/dev-python/python-xmlsec/python-xmlsec-1.3.12-r1.ebuild
+++ b/dev-python/python-xmlsec/python-xmlsec-1.3.12-r1.ebuild
@@ -9,15 +9,21 @@ PYTHON_COMPAT=( python3_{9..10} )
inherit distutils-r1
DESCRIPTION="Python bindings for the XML Security Library"
-HOMEPAGE="https://github.com/mehcode/python-xmlsec"
-SRC_URI="https://github.com/mehcode/python-xmlsec/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/mehcode/python-xmlsec/
+ https://pypi.org/project/xmlsec/
+"
+SRC_URI="
+ https://github.com/mehcode/python-xmlsec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~ppc64 x86"
RDEPEND="
- dev-libs/xmlsec:=
+ dev-libs/xmlsec:=[openssl]
dev-python/lxml[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
@@ -37,6 +43,10 @@ PATCHES=(
EPYTEST_DESELECT=(
# Fragile based on black version?
tests/test_type_stubs.py::test_xmlsec_constants_stub
+
+ # Broken with xmlsec-1.2.36+.
+ # https://github.com/xmlsec/python-xmlsec/issues/244
+ tests/test_ds.py::TestSignContext::test_sign_case5
)
distutils_enable_tests pytest