summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-12-02 11:13:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-12-02 11:13:16 +0100
commitb2e2f094624e2d5a2c0ba88c0b2d393fda39fb20 (patch)
tree5ec689de11c4bd0383ff766fa06e31e9e5ba302e
parentsys-apps/shadow: Minor ebuild adjustment (diff)
downloadgentoo-b2e2f094.tar.gz
gentoo-b2e2f094.tar.bz2
gentoo-b2e2f094.zip
net-dns/openresolv: Bump to version 3.9.2
Non-maintainer commit! Closes: https://bugs.gentoo.org/690242 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-dns/openresolv/Manifest1
-rw-r--r--net-dns/openresolv/openresolv-3.9.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-dns/openresolv/Manifest b/net-dns/openresolv/Manifest
index a95699af1762..e809ddc6ef08 100644
--- a/net-dns/openresolv/Manifest
+++ b/net-dns/openresolv/Manifest
@@ -1 +1,2 @@
DIST openresolv-3.9.0.tar.xz 18844 BLAKE2B 0aa2125d79305aab04a8d052d56328493d51aa6ff5b44fdfe08e96ccc78ae1d84f2115e5d59940e7e1cedf7e4fe7dc36a461839bcef8fc2c5b2e21242e441f36 SHA512 4498db60f0b5a762194dd3651b94cc8b01a349a8cfb891e10d040cd6b8e22fa0e9897909517831591787ad22ffad97c78d3281e32296aa1ee67de5dff9bf765e
+DIST openresolv-3.9.2.tar.xz 20200 BLAKE2B 25cb56fd85114c3866207a3bf83d1295eb135f1746f141d8cb8f0fb18cdd96e184ad3fbb47d1f65ce4193b57da61e918ca4306a502eaba650ca438589be9a29b SHA512 2f88ccbb53c6e830eeb7dd53666ee72b9fa30f38324766e1d1734896bc9b7f531e42e234c882b921c79604a3bde2877db2681bab9dd8c590f02779da908d0649
diff --git a/net-dns/openresolv/openresolv-3.9.2.ebuild b/net-dns/openresolv/openresolv-3.9.2.ebuild
new file mode 100644
index 000000000000..0d725c4c13e1
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="https://roy.marples.name/projects/openresolv"
+SRC_URI="https://roy.marples.name/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="!net-dns/resolvconf-gentoo
+ !<net-dns/dnsmasq-2.40-r1"
+RDEPEND="selinux? ( sec-policy/selinux-resolvconf )"
+
+src_configure() {
+ local myeconfargs=(
+ --prefix="${EPREFIX}"
+ --rundir="${EPREFIX}"/var/run
+ --libexecdir="${EPREFIX}"/lib/resolvconf
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_config() {
+ if [[ ${ROOT} != / ]]; then
+ eerror "We cannot configure unless \$ROOT=/"
+ return 1
+ fi
+
+ if [[ -n "$(resolvconf -l)" ]]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}