summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-12-28 19:05:50 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-28 19:32:11 +0100
commitb2e52c1d2a609382ee8f611230881773918e09c2 (patch)
tree93aab9909651ab1ecb14a8fc6fa64b3e03189e29
parentdev-libs/metee: add 3.2.4 (diff)
downloadgentoo-b2e52c1d2a609382ee8f611230881773918e09c2.tar.gz
gentoo-b2e52c1d2a609382ee8f611230881773918e09c2.tar.bz2
gentoo-b2e52c1d2a609382ee8f611230881773918e09c2.zip
dev-util/intel-graphics-system-controller: add 0.8.16
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-util/intel-graphics-system-controller/Manifest1
-rw-r--r--dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-system-controller/Manifest b/dev-util/intel-graphics-system-controller/Manifest
index fa8c3774e539..e4f098a143df 100644
--- a/dev-util/intel-graphics-system-controller/Manifest
+++ b/dev-util/intel-graphics-system-controller/Manifest
@@ -1 +1,2 @@
DIST intel-graphics-system-controller-0.8.13.tar.gz 188769 BLAKE2B 95e6929c85c299b23ba1996c1e365aad65b975c94852a427fa24b35d4a42fae1ff49ee941bc754543db52a3c79d59fbf27e635866721a51301f7623591c40012 SHA512 9ea523c168d80dadae863c89ce8abefd7510687b721f9e5a0573b28e157b7ecec9caf4717381a3bee29d59611c6f06b77f263f3973063112eb8ca3493d2bc720
+DIST intel-graphics-system-controller-0.8.16.tar.gz 192027 BLAKE2B fc97dffcffe53b92fa03b9fbcaa2f784f3fd33e4cdfa2f85548d2f6bea60bdf1868b003a45448829685fd961f9699534781de3ce43703a378168d50bf14927ce SHA512 105950a44c3b756fa4c23aa1590e2c0ae2f83af87660af14889641465433903a9e2973c8689338a716e67799098a762885933ba53c4a8de72ca4be3dbb134a84
diff --git a/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild
new file mode 100644
index 000000000000..ff1020e9561a
--- /dev/null
+++ b/dev-util/intel-graphics-system-controller/intel-graphics-system-controller-0.8.16.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="igsc"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Intel graphics system controller firmware update library"
+HOMEPAGE="https://github.com/intel/igsc"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+cli doc"
+
+RDEPEND=">=dev-libs/metee-3.2.4:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-doc/doxygen
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CLI="$(usex cli)"
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_PERF="OFF"
+ -DENABLE_WERROR="OFF"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DENABLE_TESTS="OFF"
+ )
+
+ cmake_src_configure
+}