summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-30 14:45:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-30 14:45:40 +0200
commitb2f6f16c80ac7398451a063e0b8460d144e2be5a (patch)
treeb598b838bdaac9510d1f6fa5901662ff0ffa162d
parentwww-client/firefox: add REQUIRED_USE for USE=screencast (diff)
downloadgentoo-b2f6f16c80ac7398451a063e0b8460d144e2be5a.tar.gz
gentoo-b2f6f16c80ac7398451a063e0b8460d144e2be5a.tar.bz2
gentoo-b2f6f16c80ac7398451a063e0b8460d144e2be5a.zip
www-client/firefox: set correct update channel
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-78.3.0.ebuild6
-rw-r--r--www-client/firefox/firefox-81.0.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-78.3.0.ebuild b/www-client/firefox/firefox-78.3.0.ebuild
index 3012edf2a956..a1d5ff8af43c 100644
--- a/www-client/firefox/firefox-78.3.0.ebuild
+++ b/www-client/firefox/firefox-78.3.0.ebuild
@@ -601,7 +601,6 @@ src_configure() {
--libdir="${EPREFIX}/usr/$(get_libdir)" \
--prefix="${EPREFIX}/usr" \
--target="${CHOST}" \
- --update-channel=release \
--without-ccache \
--with-intl-api \
--with-libclang-path="$(llvm-config --libdir)" \
@@ -614,6 +613,11 @@ src_configure() {
--x-includes="${SYSROOT}${EPREFIX}/usr/include" \
--x-libraries="${SYSROOT}${EPREFIX}/usr/$(get_libdir)"
+ # Set update channel
+ local update_channel=release
+ [[ ${MOZ_ESR} == 1 ]] && update_channel=esr
+ mozconfig_add_options_ac '' --update-channel=${update_channel}
+
if ! use x86 && [[ ${CHOST} != armv*h* ]] ; then
mozconfig_add_options_ac '' --enable-rust-simd
fi
diff --git a/www-client/firefox/firefox-81.0.ebuild b/www-client/firefox/firefox-81.0.ebuild
index f298f7c35b2c..c92df895d0b1 100644
--- a/www-client/firefox/firefox-81.0.ebuild
+++ b/www-client/firefox/firefox-81.0.ebuild
@@ -601,7 +601,6 @@ src_configure() {
--libdir="${EPREFIX}/usr/$(get_libdir)" \
--prefix="${EPREFIX}/usr" \
--target="${CHOST}" \
- --update-channel=release \
--without-ccache \
--with-intl-api \
--with-libclang-path="$(llvm-config --libdir)" \
@@ -614,6 +613,11 @@ src_configure() {
--x-includes="${SYSROOT}${EPREFIX}/usr/include" \
--x-libraries="${SYSROOT}${EPREFIX}/usr/$(get_libdir)"
+ # Set update channel
+ local update_channel=release
+ [[ ${MOZ_ESR} == 1 ]] && update_channel=esr
+ mozconfig_add_options_ac '' --update-channel=${update_channel}
+
if ! use x86 && [[ ${CHOST} != armv*h* ]] ; then
mozconfig_add_options_ac '' --enable-rust-simd
fi