summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-03 22:16:17 -0500
committerMatt Turner <mattst88@gentoo.org>2023-03-03 22:16:41 -0500
commitb2fbe244f8dd0a786b91db034a6c062f3ea3b541 (patch)
tree9d3eab8f2755b1e8b7ec607a6271adf4c3a3b9cb
parentmedia-fonts/sil-gentium: Version bump to 6.200 (diff)
downloadgentoo-b2fbe244.tar.gz
gentoo-b2fbe244.tar.bz2
gentoo-b2fbe244.zip
app-arch/cabextract: Version bump to 1.11
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-arch/cabextract/Manifest1
-rw-r--r--app-arch/cabextract/cabextract-1.11.ebuild68
-rw-r--r--app-arch/cabextract/cabextract-9999.ebuild12
3 files changed, 75 insertions, 6 deletions
diff --git a/app-arch/cabextract/Manifest b/app-arch/cabextract/Manifest
index 17fd6ea550ec..ad9e0071ecfc 100644
--- a/app-arch/cabextract/Manifest
+++ b/app-arch/cabextract/Manifest
@@ -1 +1,2 @@
+DIST cabextract-1.11.tar.gz 489656 BLAKE2B c0360e63359c3c3db26d442a92be8ac3f05903015be0f8fc76e81b572e882807b881756d6541aa77e55e8c083cda3363f8d2f9a32a7ab35a0b79482a9c91ef47 SHA512 416bdc5a889c3986b2a5d6ecb8526a69f2d85c34f4856da43951271ff4f31013e4197c56ea5f6b05061b511b980d5a65cb34b9b859d3013c1dbcbb89d43114f9
DIST cabextract-1.9.1.tar.gz 469369 BLAKE2B 5bfc697b40cbf47b42ab7857804b703c9622d8dae1648aae1bb5c0ec7c7978bff01b7ca2526f1b6090f193d88c00e3f49ae111f348d03fec9f575bddbb4b4096 SHA512 c354a4b20a222b40813f01baf8311c9a76611da427f9f44e977a3fd09508e24a18b486e3eef889a9debdca459f1b0c28d5d25429ccd555d3a2e4ff92d91cec14
diff --git a/app-arch/cabextract/cabextract-1.11.ebuild b/app-arch/cabextract/cabextract-1.11.ebuild
new file mode 100644
index 000000000000..6ed4e3092da5
--- /dev/null
+++ b/app-arch/cabextract/cabextract-1.11.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
+ inherit autotools git-r3
+ MY_P="${PN}-9999"
+
+ LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ MY_PV="${PV/_alpha/alpha}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
+
+ LIBMSPACK_DEPEND=">=dev-libs/libmspack-0.8_alpha:="
+fi
+
+DESCRIPTION="Extracts files from Microsoft cabinet archive files"
+HOMEPAGE="https://www.cabextract.org.uk/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="extras"
+
+DEPEND="${LIBMSPACK_DEPEND}"
+RDEPEND="${LIBMSPACK_DEPEND}
+ extras? ( dev-lang/perl )"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ # Re-create file layout from release tarball
+ pushd "${WORKDIR}" &>/dev/null || die
+ cp -aL "${S}"/${PN} "${WORKDIR}"/${PN}-source || die
+ rm -r "${S}" || die
+ mv "${WORKDIR}"/${PN}-source "${S}" || die
+ popd &>/dev/null || die
+ fi
+
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-external-libmspack=yes
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README TODO doc/magic )
+ default
+ docinto html
+ dodoc doc/wince_cab_format.html
+ if use extras; then
+ dobin src/{wince_info,wince_rename,cabinfo,cabsplit}
+ fi
+}
diff --git a/app-arch/cabextract/cabextract-9999.ebuild b/app-arch/cabextract/cabextract-9999.ebuild
index 569f885f93b4..6ed4e3092da5 100644
--- a/app-arch/cabextract/cabextract-9999.ebuild
+++ b/app-arch/cabextract/cabextract-9999.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-inherit autotools toolchain-funcs
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/kyz/libmspack.git"
- inherit git-r3
+ inherit autotools git-r3
MY_P="${PN}-9999"
LIBMSPACK_DEPEND="~dev-libs/libmspack-9999:="
else
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
MY_PV="${PV/_alpha/alpha}"
MY_P="${PN}-${MY_PV}"
SRC_URI="https://www.cabextract.org.uk/${P}.tar.gz"
@@ -45,7 +45,7 @@ src_prepare() {
default
- eautoreconf
+ [[ ${PV} == "9999" ]] && eautoreconf
}
src_configure() {