summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-01 00:58:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-01 01:19:23 -0400
commitb3279c9b37ddad40df1e6dbe5038b6f9b210b700 (patch)
treeddc11c82fdd733df1fae2176f41399ce885c4626
parentdev-python/deepdiff: Bump to 6.4.0 (diff)
downloadgentoo-b3279c9b.tar.gz
gentoo-b3279c9b.tar.bz2
gentoo-b3279c9b.zip
dev-python/sip: add 6.7.11
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-6.7.11.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index b2c6a7e2bea3..95cfcff07124 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,2 +1,3 @@
DIST sip-4.19.25.tar.gz 1056384 BLAKE2B f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98 SHA512 60fb4133c68869bf0993144978b4847d94a0f9c7b477f64a346ea133cfe35bc11820204ab327dcf9a929b6f65a26d16cc7efbce65e49967c3347b39376e57001
DIST sip-6.7.10.tar.gz 1165087 BLAKE2B 945027e741033a9d85dd9716586324d50380a1cbb4bcbe0df5e2db08697f6e088fb6778d93488c3d07947df3b57442af7a2225500efec0b274a8a9bfa177ecc8 SHA512 56f18fe6599dc74a90c07c58a7f1c23511c7f3661a3ec507d70fd2d32e636713ecd3cf1c960a3687261175c9a42df9de099e28cd1e6c0067ed755b97fc753e96
+DIST sip-6.7.11.tar.gz 1165368 BLAKE2B 62ba38ca39544e7ed0935e91729ba6f82a5e613a4b26fbf27c3708a5cb38ba0fa583ceb6a45c0c7485579f4c318fc5ac910eee8477aee6d25d33d4ae07bf527b SHA512 a9247714fd6f6e6dffff2e6b53b35a7831ced55f0706e7c883d6700f22b814dc2cf1e56e681214759c90386ff2c77cb4ace6d07cd0c8b6da0ed65444f9857056
diff --git a/dev-python/sip/sip-6.7.11.ebuild b/dev-python/sip/sip-6.7.11.ebuild
new file mode 100644
index 000000000000..d24ad8c097f4
--- /dev/null
+++ b/dev-python/sip/sip-6.7.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="
+ https://www.riverbankcomputing.com/software/sip/
+ https://pypi.org/project/sip/
+"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_sphinx doc --no-autodoc