summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-07 23:25:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-08 00:27:17 +0100
commitb337cde3b73611a933ccc7268d4aa5936e689038 (patch)
tree51e7e4899afe16b516c6ad102132f71cc79e29a5
parentdev-python/websocket-client: Bump to 1.2.3 (diff)
downloadgentoo-b337cde3b73611a933ccc7268d4aa5936e689038.tar.gz
gentoo-b337cde3b73611a933ccc7268d4aa5936e689038.tar.bz2
gentoo-b337cde3b73611a933ccc7268d4aa5936e689038.zip
dev-python/Faker: Bump to 10.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Faker/Faker-10.0.0.ebuild29
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-10.0.0.ebuild b/dev-python/Faker/Faker-10.0.0.ebuild
new file mode 100644
index 000000000000..12e618b6e887
--- /dev/null
+++ b/dev-python/Faker/Faker-10.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 518b2af26425..73867a45c17d 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,3 +1,4 @@
+DIST Faker-10.0.0.tar.gz 1198872 BLAKE2B 60e4f34a597ca11b0699c330f6cdb0f7f387bb6c54d769513f8e091d00242c7ba4e62fa6b3411ad313a4713e9311b729fb6068acfc4a02b66f07c66656677f33 SHA512 0c22b18d16815ee37d2ea79b4142100479c7b9b9f169817dc9e0fe39495f0646e8d61d704ddba7d36eefb6cb3fb744d179a57216abb15c15ee357c8b12b8b5a4
DIST Faker-9.8.1.tar.gz 1198229 BLAKE2B 8877a9da582fcd81b8b374c344343c9ba4a21d1cd0160694300030b2ace4b7b517fb8a62c1f0ffeacf3a950703b882ff5b484d54fdabc5b9c8b49658c45d421f SHA512 a93d625311358100c7a1dfe33dfda64b5890dd25e8d6e3dd095329ab2156c76abf3f00fe6b2c335316bbe3f42322adda2bcae3a9a312ddf4778d8143796667a0
DIST Faker-9.8.2.tar.gz 1198270 BLAKE2B 1a7ea02b43afe0ff494ee39dac4259e9eb67fa3230b9b5744a96b4913ac471ed3ccf29f91b2db02124dfefc232a9fae05ce7ddc6e9fd0cbf27bd94468a7702b6 SHA512 37a35a02ea81a871e77378ceecdd65a63c97dd82ba9aec04c2a8f7a827e5bdb264a6ed0927c534a67bf4b06886dcb2a98a188798fe7c860135deb8d6aa6e36e3
DIST Faker-9.8.3.tar.gz 1192380 BLAKE2B 90acea6d0d78307bc9e1e0d44ec2a1761f1039fdd0a3aad9ac495c139b87a055e8b43dc44bd7722aea52379506858548dbd6cd25c62697b3953f748e4ed053e5 SHA512 943adddc32ac275a030442c3ec0a529c3b97b35de9f245c027d21a90dcf7115753e1419b6b31c8d01f867c71a67fd469b75933d5475b343c47efc43be42df084