summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-04 05:01:39 +0000
committerSam James <sam@gentoo.org>2024-03-04 05:01:39 +0000
commitb34a8017a0faa59faac8d19621c7e9ff1fb9402e (patch)
treecbc07c47807c2eea06d502e796030005a4a35e9a
parentdev-db/mysql: filter LTO for legacy 5.7.x branch (diff)
downloadgentoo-b34a8017a0faa59faac8d19621c7e9ff1fb9402e.tar.gz
gentoo-b34a8017a0faa59faac8d19621c7e9ff1fb9402e.tar.bz2
gentoo-b34a8017a0faa59faac8d19621c7e9ff1fb9402e.zip
games-emulation/dolphin: filter LTO with USE=gui
Interaction between Qt and LTO. Bug: https://bugs.dolphin-emu.org/issues/11481 Bug: https://bugreports.qt.io/browse/QTBUG-61710 Closes: https://bugs.gentoo.org/891225 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-emulation/dolphin/dolphin-5.0_p20220520-r2.ebuild7
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/games-emulation/dolphin/dolphin-5.0_p20220520-r2.ebuild b/games-emulation/dolphin/dolphin-5.0_p20220520-r2.ebuild
index af6e7afd45e0..c1f43ed2cbd5 100644
--- a/games-emulation/dolphin/dolphin-5.0_p20220520-r2.ebuild
+++ b/games-emulation/dolphin/dolphin-5.0_p20220520-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake desktop xdg-utils pax-utils
+inherit cmake desktop flag-o-matic xdg-utils pax-utils
if [[ ${PV} == *9999 ]]
then
@@ -153,6 +153,9 @@ src_prepare() {
}
src_configure() {
+ # bug #891225 (https://bugs.dolphin-emu.org/issues/11481, QTBUG-61710)
+ use gui && filter-lto
+
local mycmakeargs=(
# Use ccache only when user did set FEATURES=ccache (or similar)
# not when ccache binary is present in system (automagic).
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 690c3afb5517..25bf321c0c70 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake desktop xdg-utils pax-utils
+inherit cmake desktop flag-o-matic xdg-utils pax-utils
if [[ ${PV} == *9999 ]]
then
@@ -151,6 +151,9 @@ src_prepare() {
}
src_configure() {
+ # bug #891225 (https://bugs.dolphin-emu.org/issues/11481, QTBUG-61710)
+ use gui && filter-lto
+
local mycmakeargs=(
# Use ccache only when user did set FEATURES=ccache (or similar)
# not when ccache binary is present in system (automagic).