summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Wozniak <kaczor982@gmail.com>2020-01-04 15:07:51 +0100
committerMatt Turner <mattst88@gentoo.org>2020-02-02 18:54:35 -0800
commitb37d174f57489d85dc1cbb543647a85de4f18646 (patch)
tree6fe87d6c0b2dfc11f0ca9acc80c189b49f80f6f4
parentx11-libs/pango: Version bump to 1.44.7 (diff)
downloadgentoo-b37d174f.tar.gz
gentoo-b37d174f.tar.bz2
gentoo-b37d174f.zip
dev-python/pygobject: Version bump to 3.34.0
Closes: https://bugs.gentoo.org/703002 Closes: https://bugs.gentoo.org/704196 Closes: https://github.com/gentoo/gentoo/pull/14238 Signed-off-by: Marcin Wozniak <y0rune@aol.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-python/pygobject/Manifest1
-rw-r--r--dev-python/pygobject/pygobject-3.34.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/pygobject/Manifest b/dev-python/pygobject/Manifest
index 072d55133556..353a2297b088 100644
--- a/dev-python/pygobject/Manifest
+++ b/dev-python/pygobject/Manifest
@@ -1,2 +1,3 @@
DIST pygobject-2.28.6.tar.xz 747248 BLAKE2B 5f92794034b2d0559a623db4a7d273a7dc3f099cae87ede91b17e81acac085a9298c6b81b45b4b8540b6a75ced97e474a993437dbfcfc2133d3321d6a979b541 SHA512 37544ea2377258758169b25a2969d5ee1c9ffb9b6e63e05bc7a0471a49ac9169c51ec587d4489172c7d256f53df878a81c1992a08059aa7e43dbbb69f799545c
DIST pygobject-3.32.1.tar.xz 551708 BLAKE2B ba7c34e4747d6a11424a23195f71877ecbd69b463b3c8aae7634a320cc8ec723e24301c0674b9ffbfdcb6d798fddddb5b772a723afc7ac28c23461e84cf7485a SHA512 5b325d0caf4f34f783fc2c664a795809f048eb1639d2f2e375fc147c852d6e29a8ab119438cac76786fb20220c72d5859cc06d6f70c29f976f6a5914e0169915
+DIST pygobject-3.34.0.tar.xz 552268 BLAKE2B a9cbeb644e0aa1b23067b591fe5c6299741395656631d39782a8c183a5d3a8e5e7f1a81acdefee186b7cc2bc34dda9271468b1828d5b9613ddc1256e24f1ecb8 SHA512 782195d22e564b88dea8d43469f0111f398b44b51a63df2fe7d07650af94d5cd037f322a5d7e405338823be3419fcdbf0113fe50b220ab1cfd07d4d01dbc4766
diff --git a/dev-python/pygobject/pygobject-3.34.0.ebuild b/dev-python/pygobject/pygobject-3.34.0.ebuild
new file mode 100644
index 000000000000..95582be28f28
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.34.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit gnome.org meson python-r1 virtualx xdg
+
+DESCRIPTION="Python bindings for GObject Introspection"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/pygobject https://wiki.gnome.org/Projects/PyGObject https://pygobject.readthedocs.io/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+cairo examples test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.48:2
+ >=dev-libs/gobject-introspection-1.54:=
+ virtual/libffi:=
+ cairo? (
+ >=dev-python/pycairo-1.11.1[${PYTHON_USEDEP}]
+ x11-libs/cairo[glib] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/atk[introspection]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection,jpeg]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ $(meson_use cairo pycairo) \
+ $(meson_use test tests) \
+ -Dpython="${EPYTHON}"
+ }
+
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ local -x GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
+
+ testing() {
+ local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
+ meson_src_test || die "test failed for ${EPYTHON}"
+ }
+ virtx python_foreach_impl testing
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+ use examples && dodoc -r examples
+}