summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 12:06:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 12:22:24 +0100
commitb386dee0b92f8afc81a5e6a0a945a21f7bd68014 (patch)
tree3a84a9f485cba8c9e27fa17ae78320ea3ac33506
parentdev-python/pytoolconfig: Bump to 1.2.5 (diff)
downloadgentoo-b386dee0b92f8afc81a5e6a0a945a21f7bd68014.tar.gz
gentoo-b386dee0b92f8afc81a5e6a0a945a21f7bd68014.tar.bz2
gentoo-b386dee0b92f8afc81a5e6a0a945a21f7bd68014.zip
dev-python/openapi-schema-validator: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/openapi-schema-validator/Manifest1
-rw-r--r--dev-python/openapi-schema-validator/openapi-schema-validator-0.4.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/openapi-schema-validator/Manifest b/dev-python/openapi-schema-validator/Manifest
index 7be8d01c359c..5bf68a4c9a6e 100644
--- a/dev-python/openapi-schema-validator/Manifest
+++ b/dev-python/openapi-schema-validator/Manifest
@@ -2,3 +2,4 @@ DIST openapi-schema-validator-0.2.3.gh.tar.gz 25501 BLAKE2B d961cabca647f59d4d41
DIST openapi-schema-validator-0.3.4.gh.tar.gz 16593 BLAKE2B 17882dff25d1bed05efa74792930a357d82cb404bbf746a6f348e9813b4af86842da1523a8e3dfaec1426c82efff6b0bddbfca89c8569ba36a4324ab4e5a418b SHA512 714f93594c875a04194a6980dc5e092866609787e424ef480d42da93c114e3b658a5efef13f78ed3db35f6e7399d7dda8adbc1d3bb8606512aa4f135edeaeb75
DIST openapi-schema-validator-0.4.0.gh.tar.gz 17070 BLAKE2B 199476dd660ab3493fe9805dc915c42f05b2bc5ca0f1f9728aa1e5afe5a923e3f84d82511572e353ab19c15b3094460dcfbde5ef1d96ca834c1da24314223046 SHA512 ce61c112c528bac022e3feb959bfe5adbac000ec0b4956f678bf61f66efdbf3a5cf912a4dfa1512858b497fdadaf533532f5a580f28f6ceea831e6b5ac98d85e
DIST openapi-schema-validator-0.4.1.gh.tar.gz 17478 BLAKE2B 0c215589eb72f97205c565bf7cfc77096dd9cf2a7d05d2ea7946fcbc3c8c9acb5702635f6cfe520993139ce9713c426f01b98d34b3c962ac918989f7d87f22c9 SHA512 e437309a6e741eaefa6b49bb038bd5976288bd6559fc6957d7029d9c0fed36ee368ac5fb26133a0fe54366da77ec649b5e44eb6a7926d9d5c49573afdfa3309b
+DIST openapi-schema-validator-0.4.2.gh.tar.gz 16785 BLAKE2B 9b1a301711087c8ff1d04ed3988ed8c7004088f8404ff103fee849b2f6f40e7492dd2daf0f6e009dcb5245cf33553bcfa4c441b66f0cbe98a7046f8bf4573ed9 SHA512 494c420d973dbe6b2b21181143f6bb16f7d4de4934eaae046fbe3bd625ab99bb4860e5c4806e01290ea701970bde741ccb6a506ddff1775b2f1b3364f4cad06e
diff --git a/dev-python/openapi-schema-validator/openapi-schema-validator-0.4.2.ebuild b/dev-python/openapi-schema-validator/openapi-schema-validator-0.4.2.ebuild
new file mode 100644
index 000000000000..eb3b0947748b
--- /dev/null
+++ b/dev-python/openapi-schema-validator/openapi-schema-validator-0.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI schema validation for Python"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-schema-validator/
+ https://pypi.org/project/openapi-schema-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-schema-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # https://github.com/p1c2u/openapi-schema-validator/issues/61
+ tests/integration/test_validators.py::TestOAS30Validator::test_format_checkers
+ tests/integration/test_validators.py::TestOAS31Validator::test_format_checkers
+)
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}