summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-10-15 16:39:02 -0700
committerDavid Seifert <soap@gentoo.org>2017-10-15 17:07:01 -0700
commitb3993d22a39b98ec80e2a809402081a352438d81 (patch)
tree0475fa9a0634c0db04ae3286f9edccbcb7463e9a
parentdev-util/min-cscope: [QA] Add cmake-utils_src_prepare (diff)
downloadgentoo-b3993d22.tar.gz
gentoo-b3993d22.tar.bz2
gentoo-b3993d22.zip
games-action/lugaru: [QA] Add cmake-utils_src_prepare
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--games-action/lugaru/lugaru-20151204-r1.ebuild3
-rw-r--r--games-action/lugaru/lugaru-20151204.ebuild7
-rw-r--r--games-action/lugaru/lugaru-9999.ebuild3
3 files changed, 9 insertions, 4 deletions
diff --git a/games-action/lugaru/lugaru-20151204-r1.ebuild b/games-action/lugaru/lugaru-20151204-r1.ebuild
index ac9ad89e8c7f..f53cecb8d748 100644
--- a/games-action/lugaru/lugaru-20151204-r1.ebuild
+++ b/games-action/lugaru/lugaru-20151204-r1.ebuild
@@ -30,7 +30,8 @@ PATCHES=(
)
src_prepare() {
- default
+ cmake-utils_src_prepare
+
sed -i \
-e "s:@GENTOO_DIR@:/usr/share/${PN}:" \
Source/OpenGL_Windows.cpp || die
diff --git a/games-action/lugaru/lugaru-20151204.ebuild b/games-action/lugaru/lugaru-20151204.ebuild
index 0a4ed3e8879a..3944efc4601d 100644
--- a/games-action/lugaru/lugaru-20151204.ebuild
+++ b/games-action/lugaru/lugaru-20151204.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,8 +25,11 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-dir.patch" )
+
src_prepare() {
- epatch "${FILESDIR}/${P}-dir.patch"
+ cmake-utils_src_prepare
+
sed -i \
-e "s:@GENTOO_DIR@:${GAMES_DATADIR}/${PN}:" \
Source/OpenGL_Windows.cpp || die
diff --git a/games-action/lugaru/lugaru-9999.ebuild b/games-action/lugaru/lugaru-9999.ebuild
index c447775fa520..2e65288097ba 100644
--- a/games-action/lugaru/lugaru-9999.ebuild
+++ b/games-action/lugaru/lugaru-9999.ebuild
@@ -35,7 +35,8 @@ PATCHES=(
)
src_prepare() {
- default
+ cmake-utils_src_prepare
+
sed -i \
-e "s:@GENTOO_DIR@:/usr/share/${PN}:" \
Source/OpenGL_Windows.cpp || die