summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 12:46:20 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 13:05:33 +0200
commitb3aba78ec2165923f5daa285011325a1e335a706 (patch)
tree814e3b18fc7a3355e45150e554ad1d6705768c74
parentdev-python/strict-rfc3339: Add pypy support (diff)
downloadgentoo-b3aba78ec2165923f5daa285011325a1e335a706.tar.gz
gentoo-b3aba78ec2165923f5daa285011325a1e335a706.tar.bz2
gentoo-b3aba78ec2165923f5daa285011325a1e335a706.zip
dev-python/rfc3986: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/rfc3986/Manifest1
-rw-r--r--dev-python/rfc3986/rfc3986-0.2.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
index b084e29d3194..c4886689af50 100644
--- a/dev-python/rfc3986/Manifest
+++ b/dev-python/rfc3986/Manifest
@@ -1 +1,2 @@
DIST rfc3986-0.2.0.tar.gz 14522 SHA256 8a7b3f6cfdfb969c2e876513e87c30ebe1e4bdc9fae4a63c701eee88bbec9b22 SHA512 e16a7b690597e1d3bce0869e1bd7aecb60926b61da38e8b7170d920d73130512d4017426461d755792c2ea691b5c01ae8955e0b9818679e795b7338794b66d83 WHIRLPOOL 03bc5ca0d5e2cc06f8bc68029dfccfa71820512b546caeaddfe66f2233a9346d4ae3123c69efaee2b90258acdb3f0cde8f2ee84f4f29c0e1375f4fb9fc56effa
+DIST rfc3986-0.2.2.tar.gz 17250 SHA256 b66238ee937485509326e0280eab4d8193df0e640936b99a6a181374dff97f7b SHA512 d6df82bce5de487a43cfd0e875d9e746e02f051fdfffa7b07564d025e77ed53ad02a09a837ba6c971b81019e091c694819de0e4ce43f19b4aa764ba21f70c054 WHIRLPOOL fc5b53681be16642947fa709232dc06e5643ddce6309bddb899abbdcac508060a84918f9b4b3b324c6de30dbd14669b92dea5ec34f39ddfb7a1289a7cf95a9ce
diff --git a/dev-python/rfc3986/rfc3986-0.2.2.ebuild b/dev-python/rfc3986/rfc3986-0.2.2.ebuild
new file mode 100644
index 000000000000..3099989634ed
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="http://tools.ietf.org/html/rfc3986 https://github.com/sigmavirus24/rfc3986 https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die
+}