summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-09 07:42:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-09 09:07:58 +0200
commitb3adefc5c8e9b0609fa52499cfa812a0e1f93414 (patch)
tree85f867d22e0d71b3418d3ddc779d94126b843aaf
parentdev-python/click: Bump to 8.0.2 (diff)
downloadgentoo-b3adefc5.tar.gz
gentoo-b3adefc5.tar.bz2
gentoo-b3adefc5.zip
dev-python/hypothesis: Bump to 6.23.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.23.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 7db5d774a62c..7041b0bd4f78 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-6.21.6.tar.gz 9166313 BLAKE2B 19ac66c1674be30e14d54faa612
DIST hypothesis-python-6.22.0.tar.gz 9166539 BLAKE2B 386c7fd4f9ff0d4d199f686f25743793de4de9f2676cf7c36c16519f5fef007f6b677bd5ef84fa975389c5fea9989dffffc8a18923699c05fecc23ef2e4dc5e6 SHA512 92352a7ba13d8a06532c6fcdb965f156c43369f18ba7c46808d9b6dde1ccdd5b4f938c1ce575d5651835bfe981d22e7a68189c93a368420c915f5d1ce9b8a205
DIST hypothesis-python-6.23.0.tar.gz 9166945 BLAKE2B 89d8a642262dfcbd36d83343c5e632653808711e186f5afae360e870eaacf050b415fd1abeb589b375136f273a53a236da8e4ab6227d94e16c58c8e9d0d3d8a9 SHA512 43d5f1a21d555e2a7942414cfb185e9201d9c5198c12551db7a50f3f118fed4dddc934767a0e7d880dfd044ac1a062b64afc92c5c3f391cedf71b829e177f21d
DIST hypothesis-python-6.23.1.tar.gz 9167114 BLAKE2B 324df90b9fc09dbaf599905b503119eed22ad32898d118d08cb5a84cbb3a514d0bfea51eca0c9878f3a330702d4822c5c311e9c6e091a6baed51285d8d326c5e SHA512 2d6a10ef6b47e0bc08c90aee62a9f009c5bfe7d64bc6f87fed72232c40a43b86e0ecc744527a611f3cfec571051c4bef3986c4e1970f92526e70bf7f5e523519
+DIST hypothesis-python-6.23.2.tar.gz 9167318 BLAKE2B 0a1ccf0235c64dd69705e48f67c132021898a024e8ae035d2ffc8a416c45443931ffff4a67a13f1c1ee7bbc2201e6f4ca5363568f0ed2ea4743ae46569e45ef1 SHA512 704b8d8c15e1fd510206c8d07f6a0f0bc81249bbc036978e4864e8ce234e35bab89069b0d5a0e958c57fe31fdb63fcc454502ac633d6fd986aaea9841383f36b
diff --git a/dev-python/hypothesis/hypothesis-6.23.2.ebuild b/dev-python/hypothesis/hypothesis-6.23.2.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.23.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}